summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD44
-rw-r--r--popcorntime-ru.desktop9
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0982944968b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = popcorntime-ru-bin
+ pkgdesc = Stream free movies and TV shows from torrents with Russian translation
+ pkgver = 0.4.4
+ pkgrel = 0
+ url = https://popcorn-ru.tk
+ arch = x86_64
+ license = GPL3
+ makedepends = unzip
+ depends = nss
+ depends = ttf-font
+ depends = libxss
+ depends = gtk2
+ depends = gtk3
+ provides = popcorntime
+ provides = popcorntime-ce
+ options = !strip
+ source = https://github.com/popcorn-time-ru/popcorn-desktop/releases/download/v0.4.4/Popcorn-Time-Ru-0.4.4-linux64.zip
+ source = popcorntime-ru.desktop
+ sha256sums = 5a890d792466f50151056ccf8c681bb809434da737fd27bb6efb9ab289b9e542
+ sha256sums = 144dc8864d74abed5022b354ecd34b9a7bc6a0f0fdd442e0bac438c2ce6c4c5b
+
+pkgname = popcorntime-ru-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e725a5d01cab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Gladyshev Ilya <fixfromdarkness@cock.li>
+
+pkgname=popcorntime-ru-bin
+_pkgname=popcorntime-ru
+pkgver=0.4.4
+pkgrel=0
+pkgdesc="Stream free movies and TV shows from torrents with Russian translation"
+arch=('x86_64')
+url="https://popcorn-ru.tk"
+license=('GPL3')
+depends=('nss' 'ttf-font' 'libxss' 'gtk2' 'gtk3')
+makedepends=('unzip')
+provides=('popcorntime' 'popcorntime-ce')
+conflicts=()
+options=('!strip')
+_zipfile="Popcorn-Time-Ru-${pkgver}-linux64.zip"
+source=("https://github.com/popcorn-time-ru/popcorn-desktop/releases/download/v${pkgver}/${_zipfile}"
+ "${_pkgname}.desktop" )
+sha256sums=('5a890d792466f50151056ccf8c681bb809434da737fd27bb6efb9ab289b9e542'
+ '144dc8864d74abed5022b354ecd34b9a7bc6a0f0fdd442e0bac438c2ce6c4c5b')
+
+package() {
+ install -dm755 "${pkgdir}/usr/share/${_pkgname}"
+ install -dm755 "${pkgdir}/usr/bin"
+
+ # Link to program
+ ln -s "../share/${_pkgname}/Popcorn-Time-Ru" "${pkgdir}/usr/bin/${_pkgname}"
+
+ # Desktop file
+ install -Dm644 "${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+
+ # Icon
+ install -Dm644 "${srcdir}/src/app/images/icon.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/${_pkgname}.png"
+
+ # Remove makepkg-created symlinks before copying content
+ rm "$_zipfile" "${_pkgname}.desktop"
+
+ # Copy complete content of source archive to /usr/share/${_pkgname}
+ cp -a "${srcdir}"/* "${pkgdir}/usr/share/${_pkgname}"
+
+ # Fix permissions
+ find "${pkgdir}/usr/share/${_pkgname}/" -perm 600 -exec chmod 644 '{}' \;
+ find "${pkgdir}/usr/share/${_pkgname}/" -perm 700 -exec chmod 755 '{}' \;
+}
diff --git a/popcorntime-ru.desktop b/popcorntime-ru.desktop
new file mode 100644
index 000000000000..0f56e7ad9846
--- /dev/null
+++ b/popcorntime-ru.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Popcorn Time RU
+Comment=Watch Movies and TV Shows instantly
+Exec=popcorntime-ru %U
+Icon=popcorntime-ru
+MimeType=application/x-bittorrent;x-scheme-handler/magnet;
+StartupNotify=false
+Categories=AudioVideo;Video;Network;Player;P2P;
+Type=Application