summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 2 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 75a5a31c268a..7c9f26686cd6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,7 +11,6 @@ pkgbase = popsift
makedepends = cmake
makedepends = git
makedepends = cuda>=7.0
- makedepends = expac
source = popsift::git+https://github.com/alicevision/popsift.git
sha256sums = SKIP
@@ -19,7 +18,6 @@ pkgname = popsift
pkgdesc = Realtime GPU implementation of SIFT, 25 fps on HD images on recent graphic cards. (DOI: 10.1145/3204949.3208136) [development headers and static libs]
depends = boost
depends = popsift-libs=1.0.0
- depends = cuda
options = staticlibs
pkgname = popsift-libs
diff --git a/PKGBUILD b/PKGBUILD
index 307f2e08d98b..234383e41a98 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@ license=('MPL2')
groups=()
conflicts=()
provides=()
-makedepends=('boost' 'cmake' 'git' 'expac')
+makedepends=('boost' 'cmake' 'git')
makedepends+=('cuda>=7.0')
checkdepends=('wget')
source=("${_name}::git+https://github.com/alicevision/popsift.git")
@@ -51,9 +51,7 @@ build() {
package_popsift() {
pkgdesc+=" [development headers and static libs]"
- _cuda_version=$(expac -Q '%v' cuda)
- _cuda_version=${_cuda_version%-[0-9]*}
- depends=('boost' "popsift-libs=${pkgver}" "cuda${_cuda_version:+=$_cuda_version}")
+ depends=('boost' "popsift-libs=${pkgver}")
optdepend=('cuda: for static cudart library')
options=('staticlibs')
make -C "$srcdir/build_static" DESTDIR="${pkgdir}" install