summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD39
2 files changed, 32 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26e7446e1ff4..19d224c7e06b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,16 @@
pkgbase = popt-deb
pkgdesc = popt with debian patches (mostly to avoid double free)
- pkgver = 1.16.10
+ pkgver = 1.18
pkgrel = 1
- url = https://github.com/azat/popt
+ url = https://github.com/rpm-software-management/popt
arch = x86_64
- license = GPL
- makedepends = autoconf
- makedepends = automake
- makedepends = gcc
- makedepends = git
- makedepends = libtool
- makedepends = make
+ license = custom
provides = popt
conflicts = popt
options = staticlibs
- source = git+https://github.com/azat/popt#branch=patched
- md5sums = SKIP
+ source = https://ftp.osuosl.org/pub/rpm/popt/releases/popt-1.x/popt-1.18.tar.gz
+ source = https://deb.debian.org/debian/pool/main/p/popt/popt_1.18-3.debian.tar.xz
+ sha256sums = 5159bc03a20b28ce363aa96765f37df99ea4d8850b1ece17d1e6ad5c24fdc5d1
+ sha256sums = 6bb1de379eb2bf0a3a9e25ce26a4dd111878699c35116fa4d45d4814280f0bc9
pkgname = popt-deb
-
diff --git a/PKGBUILD b/PKGBUILD
index 0ff2b302a2cf..0dcbae0aab1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,37 @@
-Maintainer='Azat Khuzhin <a3at.mail@gmail.com>'
+# Maintainer='Azat Khuzhin <a3at.mail@gmail.com>'
+
pkgname=popt-deb
-pkgdesc='popt with debian patches (mostly to avoid double free)'
-pkgver=1.16.10
+pkgver=1.18
+_patchver=${pkgver}-3
pkgrel=1
+pkgdesc='popt with debian patches (mostly to avoid double free)'
arch=(x86_64)
-url='https://github.com/azat/popt'
-license=('GPL')
+url="https://github.com/rpm-software-management/popt"
+license=(custom)
provides=(popt)
conflicts=(popt)
options=('staticlibs')
-makedepends=('autoconf' 'automake' 'gcc' 'git' 'libtool' 'make')
-source=('git+https://github.com/azat/popt#branch=patched')
-md5sums=(SKIP)
+source=("https://ftp.osuosl.org/pub/rpm/popt/releases/popt-1.x/popt-${pkgver}.tar.gz"
+ "https://deb.debian.org/debian/pool/main/p/popt/popt_${_patchver}.debian.tar.xz")
+sha256sums=('5159bc03a20b28ce363aa96765f37df99ea4d8850b1ece17d1e6ad5c24fdc5d1'
+ '6bb1de379eb2bf0a3a9e25ce26a4dd111878699c35116fa4d45d4814280f0bc9')
+
+prepare() {
+ cd "popt-${pkgver}"
+ for patch in ../debian/patches/*.patch; do
+ patch -p1 < $patch
+ done
+}
build() {
- cd popt
- ./autogen.sh
- ./configure --prefix=/usr --enable-static
- make
+ cd "popt-${pkgver}"
+ # Avoid stripping issue
+ CFLAGS+=" -ffat-lto-objects" ./configure --prefix=/usr --enable-static
+ make
}
package() {
- cd popt
- make DESTDIR="$pkgdir/" install
+ cd "popt-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 COPYING "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}