summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore33
-rw-r--r--PKGBUILD36
3 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ce5dbf14c83c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = postal
+ pkgdesc = An SMTP and POP benchmark
+ pkgver = 0.72
+ pkgrel = 2
+ url = http://doc.coker.com.au/projects/postal/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = gnutls
+ depends = libgcrypt
+ source = http://www.coker.com.au/postal/postal-0.72.tgz
+ sha256sums = 70d59adf8ab006a6ea389d8f276a265de743330458f5c1affb97d86bb0663bad
+ sha384sums = d5747ad8f7400d9fb2c642864c0470ccae3d28bc23e1065a4ef83262d44da198ce9337545537a053bdb13e6c3853512d
+ sha512sums = 858d5a3ec452e868d6026d631d59260eab83e90c64ce185bf9c6cecd3494c591ba7cb1455f35a5f003acbbe33f4974669e6820750e4d4ce9432d72b350263c99
+
+pkgname = postal
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0490f42ef0e2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,33 @@
+# Copyright (c) 2014 GitHub, Inc.
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# the rights to use, copy, modify, merge, publish, distribute, sublicense,
+# and/or sell copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+# DEALINGS IN THE SOFTWARE.
+
+*.tar
+*.tar.*
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+# AUR metadata
+.AURINFO
+
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dba3bb49525b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: another <code § deadcode § eu>
+# Contributor: Lazaros Koromilas <koromilaz@gmail.com>
+
+pkgname=postal
+pkgver=0.72
+pkgrel=2
+pkgdesc="An SMTP and POP benchmark"
+arch=('i686' 'x86_64')
+url="http://doc.coker.com.au/projects/postal/"
+license=('GPL')
+depends=('gnutls' 'libgcrypt')
+source=("http://www.coker.com.au/postal/$pkgname-$pkgver.tgz")
+sha256sums=('70d59adf8ab006a6ea389d8f276a265de743330458f5c1affb97d86bb0663bad')
+sha384sums=('d5747ad8f7400d9fb2c642864c0470ccae3d28bc23e1065a4ef83262d44da198ce9337545537a053bdb13e6c3853512d')
+sha512sums=('858d5a3ec452e868d6026d631d59260eab83e90c64ce185bf9c6cecd3494c591ba7cb1455f35a5f003acbbe33f4974669e6820750e4d4ce9432d72b350263c99')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+
+ sed -i 's/sbin/bin/g' Makefile*
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: