summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--LICENSE27
-rw-r--r--PKGBUILD31
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..48a9d1698a1a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = postgresql-jdbc
+ pkgdesc = The official JDBC driver for PostgreSQL. Contains JDBC 4.0 and 4.1 drivers.
+ pkgver = 9.4.1201
+ pkgrel = 2
+ url = http://jdbc.postgresql.org/
+ arch = any
+ license = Custom: BSD
+ depends = java-runtime
+ noextract = postgresql-9.4.1201.jdbc4.jar
+ noextract = postgresql-9.4.1201.jdbc41.jar
+ source = LICENSE
+ source = postgresql-jdbc-9.4.1201.jdbc4.jar::http://jdbc.postgresql.org/download/postgresql-9.4-1201.jdbc4.jar
+ source = postgresql-jdbc-9.4.1201.jdbc41.jar::http://jdbc.postgresql.org/download/postgresql-9.4-1201.jdbc41.jar
+ md5sums = da7e6f8b26deefe7c03b391454732a0d
+ md5sums = 42200af7dcc45451450e1ec6104b7336
+ md5sums = a707b13c0c067a707d41db09dc0b3342
+
+pkgname = postgresql-jdbc
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..b23f09754147
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,27 @@
+Copyright (c) 1997-2011, PostgreSQL Global Development Group
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+
+1. Redistributions of source code must retain the above copyright notice,
+ this list of conditions and the following disclaimer.
+2. Redistributions in binary form must reproduce the above copyright notice,
+ this list of conditions and the following disclaimer in the documentation
+ and/or other materials provided with the distribution.
+3. Neither the name of the PostgreSQL Global Development Group nor the names
+ of its contributors may be used to endorse or promote products derived
+ from this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE
+LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+POSSIBILITY OF SUCH DAMAGE.
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..940212818c7e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+pkgname=postgresql-jdbc
+_mainver=9.4
+_build=1201
+pkgver=${_mainver}.${_build}
+pkgrel=2
+pkgdesc="The official JDBC driver for PostgreSQL. Contains JDBC 4.0 and 4.1 drivers."
+arch=('any')
+url="http://jdbc.postgresql.org/"
+license="Custom: BSD"
+depends=('java-runtime')
+source=(LICENSE
+ postgresql-jdbc-${pkgver}.jdbc4.jar::http://jdbc.postgresql.org/download/postgresql-${_mainver}-${_build}.jdbc4.jar \
+ postgresql-jdbc-${pkgver}.jdbc41.jar::http://jdbc.postgresql.org/download/postgresql-${_mainver}-${_build}.jdbc41.jar)
+md5sums=('da7e6f8b26deefe7c03b391454732a0d'
+ '42200af7dcc45451450e1ec6104b7336'
+ 'a707b13c0c067a707d41db09dc0b3342')
+
+noextract=(postgresql-${pkgver}.jdbc4.jar postgresql-${pkgver}.jdbc41.jar)
+
+package() {
+ install -d -m755 "${pkgdir}/usr/share/java/${pkgname}"
+ install -d -m755 "${pkgdir}/usr/share/licenses/${pkgname}"
+
+ install -m644 "${srcdir}/postgresql-jdbc-${pkgver}.jdbc4.jar" "${pkgdir}/usr/share/java/${pkgname}/"
+ install -m644 "${srcdir}/postgresql-jdbc-${pkgver}.jdbc41.jar" "${pkgdir}/usr/share/java/${pkgname}/"
+
+ ln -s postgresql-jdbc-${pkgver}.jdbc4.jar "${pkgdir}/usr/share/java/${pkgname}/postgresql-jdbc4.jar"
+ ln -s postgresql-jdbc-${pkgver}.jdbc41.jar "${pkgdir}/usr/share/java/${pkgname}/postgresql-jdbc41.jar"
+
+ install -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/"
+}