summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore15
-rw-r--r--PKGBUILD36
-rwxr-xr-xpostman6.desktop12
4 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..56767f3b7a32
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = postman6-bin
+ pkgdesc = Build, test, and document your APIs faster. (Compatible with v6 team collections)
+ pkgver = 6.7.4
+ pkgrel = 1
+ url = https://learning.getpostman.com/docs/postman_pro/managing_postman_pro/migrating_to_v7/#team-user-on-v7
+ arch = x86_64
+ license = custom
+ depends = gconf
+ depends = libxss
+ depends = gtk2
+ depends = libxtst
+ depends = nss
+ depends = alsa-lib
+ source = postman6-bin-6.7.4.tar.gz::https://dl.pstmn.io/download/version/6.7.4/linux64
+ source = postman6.desktop
+ md5sums = 86d8b577e90a61949750b393097577c8
+ md5sums = fb0374754495c7c8c61b25dec799b3e2
+
+pkgname = postman6-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..400fbff6d813
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,15 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+*.crt
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d888c63dd8e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Zhanibek Adilbekov <zhanibek.adilbekov@pm.me>
+pkgname=postman6-bin
+pkgver=6.7.4
+pkgrel=1
+pkgdesc="Build, test, and document your APIs faster. (Compatible with v6 team collections)"
+arch=('x86_64')
+url="https://learning.getpostman.com/docs/postman_pro/managing_postman_pro/migrating_to_v7/#team-user-on-v7"
+license=('custom')
+source=(
+ "$pkgname-$pkgver.tar.gz::https://dl.pstmn.io/download/version/${pkgver}/linux64"
+ "postman6.desktop"
+)
+md5sums=('86d8b577e90a61949750b393097577c8'
+ 'fb0374754495c7c8c61b25dec799b3e2')
+depends=(gconf libxss gtk2 libxtst nss alsa-lib)
+package() {
+ install -dm755 "${pkgdir}/opt/"
+ chmod -R 755 "Postman"
+ cp -r "Postman" "${pkgdir}/opt/postman6"
+ chmod -R 755 "${pkgdir}/opt/postman6"
+ install -dm755 "${pkgdir}/usr/bin"
+ ln -s "/opt/postman6/Postman" "${pkgdir}/usr/bin/postman6"
+ # License
+ install -D -m644 "Postman/app/LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ # Chromium License
+ install -D -m644 "Postman/app/LICENSES.chromium.html" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSES.chromium.html"
+ # Desktop file
+ install -D -m644 "postman6.desktop" \
+ "${pkgdir}/usr/share/applications/postman6.desktop"
+ # Icon
+ install -d -m755 "${pkgdir}/usr/share/icons/hicolor/128x128/apps"
+ ln -s "/opt/postman/app/resources/app/assets/icon.png" \
+ "${pkgdir}/usr/share/icons/hicolor/128x128/apps/postman6.png"
+}
diff --git a/postman6.desktop b/postman6.desktop
new file mode 100755
index 000000000000..26447ff6aa2f
--- /dev/null
+++ b/postman6.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Name=Postman 6
+Comment=Build, test, and document your APIs faster
+Path=/opt/postman6
+Exec=postman6 %U
+Icon=postman6
+Type=Application
+StartupNotify=true
+Categories=Development;Utility;
+StartupWMClass=postman
+MimeType=x-scheme-handler/postman
+