summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD25
-rw-r--r--PothosFlow.desktop7
3 files changed, 31 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 295246f8108e..7a21c5d419f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Wed Dec 27 17:26:03 UTC 2017
pkgbase = pothos
pkgdesc = The Pothos data-flow framework
pkgver = 0.6.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/pothosware/PothosCore/wiki
arch = i686
arch = x86_64
@@ -12,10 +10,13 @@ pkgbase = pothos
makedepends = nlohmann-json
depends = python
depends = poco
+ depends = qwt
depends = soapysdr-git
depends = portaudio
source = git+https://github.com/pothosware/PothosCore.git#tag=pothos-0.6.0
+ source = PothosFlow.desktop
sha256sums = SKIP
+ sha256sums = 4ace40dfff405cf861845cc0f9cf772a39aabc7f3447f5fdf2d0cb74f9b166c4
pkgname = pothos
diff --git a/PKGBUILD b/PKGBUILD
index 7b6dfb7691be..754c021c2e1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,27 @@
pkgname=pothos
pkgver=0.6.0
-pkgrel=2
+pkgrel=3
pkgdesc="The Pothos data-flow framework"
arch=('i686' 'x86_64')
url="https://github.com/pothosware/PothosCore/wiki"
license=('boost')
-depends=('python' 'poco' 'soapysdr-git' 'portaudio')
+depends=('python' 'poco' 'qwt' 'soapysdr-git' 'portaudio')
makedepends=('git' 'nlohmann-json')
-source=("git+https://github.com/pothosware/PothosCore.git#tag=pothos-$pkgver")
-sha256sums=('SKIP')
+source=(
+ "git+https://github.com/pothosware/PothosCore.git#tag=pothos-$pkgver"
+ "PothosFlow.desktop"
+)
+sha256sums=(
+ 'SKIP'
+ '4ace40dfff405cf861845cc0f9cf772a39aabc7f3447f5fdf2d0cb74f9b166c4'
+)
prepare() {
cd "$srcdir/PothosCore"
- git submodule update --init --recursive
+ git submodule init
+ git submodule deinit poco
+ git submodule update --recursive
}
build() {
@@ -24,6 +32,9 @@ build() {
cmake \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DENABLE_INTERNAL_POCO=OFF \
+ -DENABLE_INTERNAL_MUPARSERX=ON \
+ -DENABLE_INTERNAL_SPUCE=ON \
"$srcdir/PothosCore"
make
}
@@ -31,4 +42,8 @@ build() {
package() {
cd "$srcdir/pothos-build"
make DESTDIR="$pkgdir" install
+
+ install -Dm644 "$srcdir/PothosFlow.desktop" "$pkgdir/usr/share/applications/PothosFlow.desktop"
+ install -d "$pkgdir/usr/share/pixmaps"
+ convert "$srcdir/PothosCore/flow/icons/PothosFlow.ico" "$pkgdir/usr/share/pixmaps/PothosFlow.png"
}
diff --git a/PothosFlow.desktop b/PothosFlow.desktop
new file mode 100644
index 000000000000..8e3450da8f84
--- /dev/null
+++ b/PothosFlow.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=Pothos Flow
+Exec=/usr/bin/PothosFlow %F
+Icon=/usr/share/pixmaps/PothosFlow.png
+Terminal=false
+Type=Application
+Categories=Development;