summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD15
-rw-r--r--spuce-qt-workaround.diff20
3 files changed, 9 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f10bb947c1c4..6447332e7917 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pothos
pkgdesc = The Pothos data-flow framework
- pkgver = 0.6.1
+ pkgver = 0.7.0
pkgrel = 1
url = https://github.com/pothosware/PothosCore/wiki
arch = i686
@@ -10,14 +10,11 @@ pkgbase = pothos
makedepends = nlohmann-json
depends = python
depends = poco
- depends = qwt
- depends = soapysdr-git
+ depends = soapysdr
depends = portaudio
- source = git+https://github.com/pothosware/PothosCore.git#tag=pothos-0.6.1
- source = spuce-qt-workaround.diff
+ source = git+https://github.com/pothosware/PothosCore.git#tag=pothos-0.7.0
source = PothosFlow.desktop
sha256sums = SKIP
- sha256sums = 3bc94fcdd8a944a58906294d35ec8e2bde2ae6d53806f3413c8c302172058f3f
sha256sums = 4ace40dfff405cf861845cc0f9cf772a39aabc7f3447f5fdf2d0cb74f9b166c4
pkgname = pothos
diff --git a/PKGBUILD b/PKGBUILD
index 2b26b627965c..f2210fb0a35e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,20 @@
# Contributor: Sebastien Chassot (sinux) <seba.ptl@sinux.net>
pkgname=pothos
-pkgver=0.6.1
+pkgver=0.7.0
pkgrel=1
pkgdesc="The Pothos data-flow framework"
arch=('i686' 'x86_64')
url="https://github.com/pothosware/PothosCore/wiki"
license=('boost')
-depends=('python' 'poco' 'qwt' 'soapysdr-git' 'portaudio')
+depends=('python' 'poco' 'soapysdr' 'portaudio')
makedepends=('git' 'nlohmann-json')
source=(
"git+https://github.com/pothosware/PothosCore.git#tag=pothos-$pkgver"
- "spuce-qt-workaround.diff"
"PothosFlow.desktop"
)
sha256sums=(
'SKIP'
- '3bc94fcdd8a944a58906294d35ec8e2bde2ae6d53806f3413c8c302172058f3f'
'4ace40dfff405cf861845cc0f9cf772a39aabc7f3447f5fdf2d0cb74f9b166c4'
)
@@ -25,10 +23,9 @@ prepare() {
cd "$srcdir/PothosCore"
git submodule init
git submodule deinit poco
- git submodule update --recursive --force
-
- cd spuce
- git apply "$srcdir/spuce-qt-workaround.diff"
+ git submodule update --recursive
+ # Init submodules in plotters
+ git submodule update --init --recursive plotters
}
build() {
@@ -47,7 +44,7 @@ build() {
package() {
cd "$srcdir/pothos-build"
make DESTDIR="$pkgdir" install
-
+
install -Dm644 "$srcdir/PothosFlow.desktop" "$pkgdir/usr/share/applications/PothosFlow.desktop"
install -Dm644 "$srcdir/PothosCore/flow/icons/PothosFlow.png" "$pkgdir/usr/share/pixmaps/PothosFlow.png"
}
diff --git a/spuce-qt-workaround.diff b/spuce-qt-workaround.diff
deleted file mode 100644
index 1a575f538f31..000000000000
--- a/spuce-qt-workaround.diff
+++ /dev/null
@@ -1,20 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 5a1fe0a..6ce4b17 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -28,10 +28,11 @@ SET(SPUCE_SOVER "${SPUCE_LIBVER}")
- set(SPUCE_VERSION "${SPUCE_LIBVER}")
-
- add_subdirectory(spuce)
--FIND_PACKAGE(Qt5 COMPONENTS Gui Core Widgets)
--if (NOT Qt5_FOUND)
-- message(STATUS "QT5 not found - will skip building QT5 Apps")
--endif()
-+#FIND_PACKAGE(Qt5 COMPONENTS Gui Core Widgets)
-+#if (NOT Qt5_FOUND)
-+# message(STATUS "QT5 not found - will skip building QT5 Apps")
-+#endif()
-+SET(Qt5_FOUND FALSE)
- cmake_dependent_option(ENABLE_GUI "Enable QT application" ON "Qt5_FOUND" OFF)
- add_feature_info(ENABLE_GUI ENABLE_GUI "This enables the QT applications to be built")
- if (ENABLE_GUI)