summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD4
-rw-r--r--injector_index.js.patch13
-rw-r--r--injector_main.js.patch18
3 files changed, 18 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 144cf22b6744..f9f6a879c081 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Szentesi Botond
pkgname=powercord-git
_pkgname=powercord
-pkgver=r1178.41cb7ce
-pkgrel=5
+pkgver=r1208.76108c4
+pkgrel=1
pkgdesc="A lightweight discord client mod focused on simplicity and performance."
arch=("any")
url="https://github.com/powercord-org/$_pkgname"
diff --git a/injector_index.js.patch b/injector_index.js.patch
index 2ec78e0b08a4..7e0ca1691b55 100644
--- a/injector_index.js.patch
+++ b/injector_index.js.patch
@@ -1,12 +1,13 @@
---- /home/botond/Downloads/temp/powercord/injectors/index.js 2020-08-14 23:38:07.596542247 +0200
-+++ ./index.js 2020-08-15 13:34:31.166710654 +0200
-@@ -1,3 +1,9 @@
+--- ./powercord/injectors/index.js 2020-09-14 22:56:56.712657163 +0200
++++ ./index.js.patched 2020-09-14 23:13:59.510168597 +0200
+@@ -1,3 +1,10 @@
+#!/usr/bin/env node
+
+if(process.env.USER != "root") {
+ console.log("You need to run powercord as root.");
+ process.exit(1);
+}
- // Perform checks
- require('./env_check')();
-
++
+ /**
+ * Copyright (c) 2018-2020 aetheryx & Bowser65
+ * All Rights Reserved. Licensed under the Porkord License
diff --git a/injector_main.js.patch b/injector_main.js.patch
index 56cd83fd8333..1e1af3466df7 100644
--- a/injector_main.js.patch
+++ b/injector_main.js.patch
@@ -1,11 +1,11 @@
---- ../powercord/injectors/main.js 2020-08-14 23:38:07.596542247 +0200
-+++ ./main.js 2020-08-15 13:46:16.208269548 +0200
-@@ -9,7 +9,7 @@
- exports.inject = async ({ getAppDir }) => {
- const appDir = await getAppDir();
- if (await exists(appDir)) {
-- console.log('Looks like you already have an injector in place. Try uninjecting (`npm run unplug`) and try again.');
+--- powercord/injectors/main.js 2020-09-14 22:56:56.715990496 +0200
++++ ./main.js.patched 2020-09-14 23:34:13.970823525 +0200
+@@ -17,7 +17,7 @@
+ * @todo: verify if there is nothing in discord_desktop_core as well
+ * @todo: prompt to automatically uninject and continue
+ */
+- console.log('Looks like you already have an injector in place. Try unplugging (`npm run unplug`) and try again.', '\n');
+ console.log('Looks like you already have an injector in place. Try uninjecting (`powercord uninject`) and try again.');
+ console.log(`${AnsiEscapes.YELLOW}NOTE:${AnsiEscapes.RESET} If you already have BetterDiscord or another client mod injected, Powercord cannot run along with it!`);
+ console.log('Read our FAQ for more details: https://powercord.dev/faq#bd-and-pc');
return false;
- }
-