summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rwxr-xr-xbuild.sh83
3 files changed, 42 insertions, 58 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5e767740954..5c21a8a047df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = powershell
pkgdesc = A cross-platform automation and configuration tool/framework (latest release)
- pkgver = 6.0.0.beta.7
+ pkgver = 6.0.0.beta.8
pkgrel = 1
url = https://github.com/PowerShell/PowerShell
install = powershell.install
@@ -10,14 +10,14 @@ pkgbase = powershell
makedepends = cmake
makedepends = dotnet-sdk-2.0
depends = icu
- source = powershell::git+https://github.com/PowerShell/PowerShell.git#tag=v6.0.0-beta.7
+ source = powershell::git+https://github.com/PowerShell/PowerShell.git#tag=v6.0.0-beta.8
source = pester::git+https://github.com/PowerShell/psl-pester.git#branch=develop
source = googletest::git+https://github.com/google/googletest.git
source = build.sh
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
- md5sums = ae733aaf023f7d07e6ed9e8fffcd8ff1
+ md5sums = 4c096f1ce88fd387c9ec81f7ac0581ea
pkgname = powershell
diff --git a/PKGBUILD b/PKGBUILD
index 1a1ce6afcd40..df127dc63b40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Max Liebkies <mail@maxliebkies.de>
pkgname=powershell
-_pkgver=6.0.0-beta.7
+_pkgver=6.0.0-beta.8
pkgver=${_pkgver/-/.}
pkgrel=1
pkgdesc="A cross-platform automation and configuration tool/framework (latest release)"
@@ -18,7 +18,7 @@ source=($pkgname::git+https://github.com/PowerShell/PowerShell.git#tag=v$_pkgver
md5sums=('SKIP'
'SKIP'
'SKIP'
- 'ae733aaf023f7d07e6ed9e8fffcd8ff1')
+ '4c096f1ce88fd387c9ec81f7ac0581ea')
install=powershell.install
prepare() {
@@ -34,18 +34,11 @@ prepare() {
build() {
cd $pkgname
-
- pushd src/libpsl-native
- cmake .
- make -j
- popd
-
"$srcdir"/build.sh
}
check() {
cd $pkgname/src/libpsl-native
-
make test
}
diff --git a/build.sh b/build.sh
index 33c4d7452cc7..c49ae5bed854 100755
--- a/build.sh
+++ b/build.sh
@@ -1,20 +1,14 @@
#!/usr/bin/env bash
set -e
-if hash powershell 2>/dev/null; then
- echo 'Continuing with `powershell -noprofile -c Start-PSBuild`'
- powershell -noprofile -c "Import-Module ./build.psm1; Start-PSBuild"
-else
- echo 'Continuing with full manual build'
-
- ## Restore
- dotnet restore src/powershell-unix
- dotnet restore src/ResGen
- dotnet restore src/TypeCatalogGen
-
- ## Setup the build target to gather dependency information
- targetFile="$(pwd)/src/Microsoft.PowerShell.SDK/obj/Microsoft.PowerShell.SDK.csproj.TypeCatalog.targets"
- cat > $targetFile <<-"EOF"
+## Restore
+dotnet restore src/powershell-unix
+dotnet restore src/ResGen
+dotnet restore src/TypeCatalogGen
+
+## Setup the build target to gather dependency information
+targetFile="$(pwd)/src/Microsoft.PowerShell.SDK/obj/Microsoft.PowerShell.SDK.csproj.TypeCatalog.targets"
+cat > $targetFile <<-"EOF"
<Project>
<Target Name="_GetDependencies"
DependsOnTargets="ResolveAssemblyReferencesDesignTime">
@@ -25,35 +19,32 @@ else
</Target>
</Project>
EOF
- dotnet msbuild src/Microsoft.PowerShell.SDK/Microsoft.PowerShell.SDK.csproj /t:_GetDependencies "/property:DesignTimeBuild=true;_DependencyFile=$(pwd)/src/TypeCatalogGen/powershell.inc" /nologo
-
- ## Generate 'powershell.version'
- git --git-dir="$(pwd)/.git" describe --dirty --abbrev=60 > "$(pwd)/powershell.version"
-
- ## create the telemetry flag file
- touch "$(pwd)/DELETE_ME_TO_DISABLE_CONSOLEHOST_TELEMETRY"
-
- ## Generate resource binding C# files
- pushd src/ResGen
- dotnet run
- popd
-
- ## Generate 'CorePsTypeCatalog.cs'
- pushd src/TypeCatalogGen
- dotnet run ../Microsoft.PowerShell.CoreCLR.AssemblyLoadContext/CorePsTypeCatalog.cs powershell.inc
- popd
-
- ## Build native component
- pushd src/libpsl-native
- cmake -DCMAKE_BUILD_TYPE=Debug .
- make -j
- make test
- popd
-
- ## Build powershell core
- rawRid="$(dotnet --info | grep RID)"
- rid=${rawRid##* } # retain the part after the last space
- dotnet publish --configuration Linux src/powershell-unix/ --output bin --runtime $rid
-
- echo 'You can run powershell from bin/, but some modules that are normally added by the Restore-PSModule step will not be available.'
-fi
+dotnet msbuild src/Microsoft.PowerShell.SDK/Microsoft.PowerShell.SDK.csproj /t:_GetDependencies "/property:DesignTimeBuild=true;_DependencyFile=$(pwd)/src/TypeCatalogGen/powershell.inc" /nologo
+
+## Generate 'powershell.version'
+git --git-dir="$(pwd)/.git" describe --dirty --abbrev=60 > "$(pwd)/powershell.version"
+
+## create the telemetry flag file
+touch "$(pwd)/DELETE_ME_TO_DISABLE_CONSOLEHOST_TELEMETRY"
+
+## Generate resource binding C# files
+pushd src/ResGen
+dotnet run
+popd
+
+## Generate 'CorePsTypeCatalog.cs'
+pushd src/TypeCatalogGen
+dotnet run ../System.Management.Automation/CoreCLR/CorePsTypeCatalog.cs powershell.inc
+popd
+
+## Build native component
+pushd src/libpsl-native
+cmake -DCMAKE_BUILD_TYPE=Debug .
+make -j
+make test
+popd
+
+## Build powershell core
+rawRid="$(dotnet --info | grep RID)"
+rid=${rawRid##* } # retain the part after the last space
+dotnet publish --configuration Linux src/powershell-unix/ --output bin --runtime $rid