summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
-rwxr-xr-xbuild.sh2
-rw-r--r--dotnet-version.patch9
4 files changed, 22 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3515255938d8..7e988a8e51a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = powershell
pkgdesc = A cross-platform automation and configuration tool/framework (latest release)
- pkgver = 6.0.0.rc
+ pkgver = 6.0.0.rc.2
pkgrel = 1
url = https://github.com/PowerShell/PowerShell
install = powershell.install
@@ -10,14 +10,16 @@ pkgbase = powershell
makedepends = cmake
makedepends = dotnet-sdk-2.0
depends = icu
- source = powershell::git+https://github.com/PowerShell/PowerShell.git#tag=v6.0.0-rc
+ source = powershell::git+https://github.com/PowerShell/PowerShell.git#tag=v6.0.0-rc.2
source = pester::git+https://github.com/PowerShell/psl-pester.git#branch=develop
source = googletest::git+https://github.com/google/googletest.git
source = build.sh
+ source = dotnet-version.patch
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
- md5sums = 8f3cdd1186321e277b53bb8596746d03
+ md5sums = a0d7e3fa753f74e9722f71a5ab3da6d9
+ md5sums = 7fc09756121a31bc336498a18edfe6da
pkgname = powershell
diff --git a/PKGBUILD b/PKGBUILD
index 4da77b933fc9..1d35bc2ff6c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=powershell
binaryname=pwsh
-_pkgver=6.0.0-rc
+_pkgver=6.0.0-rc.2
pkgver=${_pkgver/-/.}
pkgrel=1
pkgdesc='A cross-platform automation and configuration tool/framework (latest release)'
@@ -15,11 +15,13 @@ depends=('icu')
source=($pkgname::git+https://github.com/PowerShell/PowerShell.git#tag=v$_pkgver
pester::git+https://github.com/PowerShell/psl-pester.git#branch=develop
googletest::git+https://github.com/google/googletest.git
- build.sh)
+ build.sh
+ dotnet-version.patch)
md5sums=('SKIP'
'SKIP'
'SKIP'
- '8f3cdd1186321e277b53bb8596746d03')
+ 'a0d7e3fa753f74e9722f71a5ab3da6d9'
+ '7fc09756121a31bc336498a18edfe6da')
install=powershell.install
prepare() {
@@ -30,7 +32,7 @@ prepare() {
git submodule update
git clean -dfx
- sed -i -e 's/hash powershell/\/bin\/false/g' ../build.sh
+ cat $srcdir/dotnet-version.patch | patch -p1
}
build() {
diff --git a/build.sh b/build.sh
index d245c35e7ae5..7ac578d797fa 100755
--- a/build.sh
+++ b/build.sh
@@ -1,6 +1,8 @@
#!/usr/bin/env bash
set -e
+export DOTNET_SKIP_FIRST_TIME_EXPERIENCE=true
+
## Restore
dotnet restore src/powershell-unix
dotnet restore src/ResGen
diff --git a/dotnet-version.patch b/dotnet-version.patch
new file mode 100644
index 000000000000..2d71bff05d23
--- /dev/null
+++ b/dotnet-version.patch
@@ -0,0 +1,9 @@
+--- a/global.json
++++ b/global.json
+@@ -1,5 +1,5 @@
+ {
+ "sdk": {
+- "version": "2.0.2"
++ "version": "2.1.3"
+ }
+ }