summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore1
-rw-r--r--Microsoft.PowerShell.SDK.csproj.TypeCatalog.targets9
-rw-r--r--PKGBUILD19
4 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44d352985dd7..bd45d6698859 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,9 +14,11 @@ pkgbase = powershell
source = powershell::git+https://github.com/PowerShell/PowerShell.git#tag=v6.2.0
source = powershell-native::git+https://github.com/PowerShell/PowerShell-Native.git
source = googletest::git+https://github.com/google/googletest.git
+ source = Microsoft.PowerShell.SDK.csproj.TypeCatalog.targets
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = 56f02557575a6022b60be609951eee78
pkgname = powershell
diff --git a/.gitignore b/.gitignore
index 17d2c4ac9a93..324cc497a218 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,4 +3,5 @@ pester/
pkg/
*.pkg.tar
powershell/
+powershell-native/
src/
diff --git a/Microsoft.PowerShell.SDK.csproj.TypeCatalog.targets b/Microsoft.PowerShell.SDK.csproj.TypeCatalog.targets
new file mode 100644
index 000000000000..85ece3e539a3
--- /dev/null
+++ b/Microsoft.PowerShell.SDK.csproj.TypeCatalog.targets
@@ -0,0 +1,9 @@
+<Project>
+ <Target Name="_GetDependencies"
+ DependsOnTargets="ResolveAssemblyReferencesDesignTime">
+ <ItemGroup>
+ <_RefAssemblyPath Include="%(_ReferencesFromRAR.HintPath)%3B" Condition=" '%(_ReferencesFromRAR.NuGetPackageId)' != 'Microsoft.Management.Infrastructure' "/>
+ </ItemGroup>
+ <WriteLinesToFile File="$(_DependencyFile)" Lines="@(_RefAssemblyPath)" Overwrite="true" />
+ </Target>
+</Project>
diff --git a/PKGBUILD b/PKGBUILD
index 53d5ba120ecb..37d56b171ef5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,10 +14,12 @@ makedepends=('git' 'cmake' 'dotnet-sdk>=2.0')
depends=('icu' 'openssl-1.0')
source=($pkgname::git+https://github.com/PowerShell/PowerShell.git#tag=v$_pkgver
powershell-native::git+https://github.com/PowerShell/PowerShell-Native.git
- googletest::git+https://github.com/google/googletest.git)
+ googletest::git+https://github.com/google/googletest.git
+ "Microsoft.PowerShell.SDK.csproj.TypeCatalog.targets")
md5sums=('SKIP'
'SKIP'
- 'SKIP')
+ 'SKIP'
+ '56f02557575a6022b60be609951eee78')
install=powershell.install
prepare() {
@@ -39,18 +41,7 @@ build() {
dotnet restore src/TypeCatalogGen
## Setup the build target to gather dependency information
- targetFile="src/Microsoft.PowerShell.SDK/obj/Microsoft.PowerShell.SDK.csproj.TypeCatalog.targets"
- cat > $targetFile <<-"EOF"
- <Project>
- <Target Name="_GetDependencies"
- DependsOnTargets="ResolveAssemblyReferencesDesignTime">
- <ItemGroup>
- <_RefAssemblyPath Include="%(_ReferencesFromRAR.HintPath)%3B" Condition=" '%(_ReferencesFromRAR.NuGetPackageId)' != 'Microsoft.Management.Infrastructure' "/>
- </ItemGroup>
- <WriteLinesToFile File="$(_DependencyFile)" Lines="@(_RefAssemblyPath)" Overwrite="true" />
- </Target>
- </Project>
-EOF
+ cp "$srcdir/Microsoft.PowerShell.SDK.csproj.TypeCatalog.targets" "src/Microsoft.PowerShell.SDK/obj/Microsoft.PowerShell.SDK.csproj.TypeCatalog.targets"
dotnet msbuild src/Microsoft.PowerShell.SDK/Microsoft.PowerShell.SDK.csproj /t:_GetDependencies "/property:DesignTimeBuild=true;_DependencyFile=$(pwd)/src/TypeCatalogGen/powershell.inc" /nologo
## Generate 'powershell.version'