summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD26
-rw-r--r--os-release9
3 files changed, 15 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 991fcd895ad9..dcc69dce21a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,22 @@
pkgbase = powershell
pkgdesc = A cross-platform automation and configuration tool/framework (latest release)
- pkgver = 6.0.0.beta.3
- pkgrel = 2
+ pkgver = 6.0.0.beta.5
+ pkgrel = 1
url = https://github.com/PowerShell/PowerShell
install = powershell.install
arch = x86_64
license = MIT
makedepends = git
makedepends = cmake
- makedepends = proot
makedepends = dotnet-sdk-2.0
depends = icu
conflicts = powershell-git
- source = powershell::git+https://github.com/PowerShell/PowerShell.git#tag=v6.0.0-beta.3
+ source = powershell::git+https://github.com/PowerShell/PowerShell.git#tag=v6.0.0-beta.5
source = pester::git+https://github.com/PowerShell/psl-pester.git#branch=develop
source = googletest::git+https://github.com/google/googletest.git
- source = os-release
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
- md5sums = f5841baa62b1322c07f9394940cec818
pkgname = powershell
diff --git a/PKGBUILD b/PKGBUILD
index d3ac2890644c..fdf62b24613f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
# Maintainer: Kyle Sferrazza <kyle.sferrazza@gmail.com>
+# Contributor: Max Liebkies <mail@maxliebkies.de>
pkgname=powershell
-_pkgver=6.0.0-beta.3
+_pkgver=6.0.0-beta.5
pkgver=${_pkgver/-/.}
-pkgrel=2
+pkgrel=1
pkgdesc="A cross-platform automation and configuration tool/framework (latest release)"
arch=('x86_64')
url="https://github.com/PowerShell/PowerShell"
license=('MIT')
-makedepends=('git' 'cmake' 'proot' 'dotnet-sdk-2.0')
+makedepends=('git' 'cmake' 'dotnet-sdk-2.0')
depends=('icu')
conflicts=('powershell-git')
source=($pkgname::git+https://github.com/PowerShell/PowerShell.git#tag=v$_pkgver
pester::git+https://github.com/PowerShell/psl-pester.git#branch=develop
- googletest::git+https://github.com/google/googletest.git
- os-release)
+ googletest::git+https://github.com/google/googletest.git)
md5sums=('SKIP'
'SKIP'
- 'SKIP'
- 'f5841baa62b1322c07f9394940cec818')
+ 'SKIP')
install=powershell.install
prepare() {
@@ -28,6 +27,8 @@ prepare() {
git config submodule.src/libpsl-native/test/googletest.url "$srcdir"/googletest
git submodule update
git clean -dfx
+
+ sed -i -e 's/hash powershell/\/bin\/false/g' build.sh
}
build() {
@@ -38,15 +39,12 @@ build() {
make -j
popd
- PROOT_NO_SECCOMP=1 \
- proot -b "$srcdir"/os-release:/etc/os-release "$srcdir"/powershell/build.sh
+ "$srcdir"/powershell/build.sh
}
check() {
cd $pkgname/src/libpsl-native
- PROOT_NO_SECCOMP=1 \
- proot -b "$srcdir"/os-release:/etc/os-release \
make test
}
@@ -55,12 +53,12 @@ package() {
cd $pkgname/src/powershell-unix
mkdir -p "$pkgdir"/usr/lib/$pkgname
- cp -a bin/Linux/netcoreapp*/ubuntu.16.04-x64 "$pkgdir"/usr/lib/$pkgname
- chmod 755 "$pkgdir"/usr/lib/$pkgname/ubuntu.16.04-x64/$pkgname
+ cp -a bin/Linux/netcoreapp*/linux-x64 "$pkgdir"/usr/lib/$pkgname
+ chmod 755 "$pkgdir"/usr/lib/$pkgname/linux-x64/$pkgname
mkdir -p "$pkgdir"/usr/share/licenses/$pkgname
cp ../../LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
mkdir -p "$pkgdir"/usr/bin
- ln -s /usr/lib/$pkgname/ubuntu.16.04-x64/$pkgname "$pkgdir"/usr/bin/powershell
+ ln -s /usr/lib/$pkgname/linux-x64/$pkgname "$pkgdir"/usr/bin/powershell
}
diff --git a/os-release b/os-release
deleted file mode 100644
index 5cff123fce0a..000000000000
--- a/os-release
+++ /dev/null
@@ -1,9 +0,0 @@
-NAME="Ubuntu"
-VERSION="16.04.1 LTS"
-ID=ubuntu
-ID_LIKE=debian
-PRETTY_NAME="Ubuntu 16.04.1 LTS"
-VERSION_ID="16.04"
-HOME_URL="http://www.ubuntu.com/"
-SUPPORT_URL="http://help.ubuntu.com/"
-BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/" \ No newline at end of file