summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c674076612d..3255f5a4abf9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = powershell
- pkgdesc = A cross-platform automation and configuration tool/framework
+ pkgdesc = A cross-platform automation and configuration tool/framework (latest release)
pkgver = 6.0.0.beta.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/PowerShell/PowerShell
arch = x86_64
license = MIT
@@ -10,7 +10,6 @@ pkgbase = powershell
makedepends = proot
makedepends = dotnet-cli-git
depends = icu
- conflicts = powershell-git
source = powershell::git+https://github.com/PowerShell/PowerShell.git#tag=v6.0.0-beta.2
source = pester::git+https://github.com/PowerShell/psl-pester.git#branch=develop
source = googletest::git+https://github.com/google/googletest.git
diff --git a/PKGBUILD b/PKGBUILD
index 09be4ff51677..bf0cb9fb6608 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,13 @@
pkgname=powershell
_pkgver=6.0.0-beta.2
pkgver=${_pkgver/-/.}
-pkgrel=1
-pkgdesc="A cross-platform automation and configuration tool/framework"
+pkgrel=2
+pkgdesc="A cross-platform automation and configuration tool/framework (latest release)"
arch=('x86_64')
url="https://github.com/PowerShell/PowerShell"
license=('MIT')
makedepends=('git' 'cmake' 'proot' 'dotnet-cli-git')
depends=('icu')
-conflicts=('powershell-git')
source=($pkgname::git+https://github.com/PowerShell/PowerShell.git#tag=v$_pkgver
pester::git+https://github.com/PowerShell/psl-pester.git#branch=develop
googletest::git+https://github.com/google/googletest.git
@@ -61,5 +60,5 @@ package() {
cp ../../LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
mkdir -p "$pkgdir"/usr/bin
- ln -s /usr/lib/$pkgname/ubuntu.16.04-x64/powershell "$pkgdir"/usr/bin/powershell
+ ln -s /usr/lib/$pkgname/ubuntu.16.04-x64/$pkgname "$pkgdir"/usr/bin/powershell
}