summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD36
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d30d014ae730
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = powertabeditor-git
+ pkgdesc = Guitar tablature viewer and editor
+ pkgver = 2.0.0.alpha19.r61.g96550b3
+ pkgrel = 1
+ url = https://powertab.github.io/
+ arch = x86_64
+ license = GPL-3.0-only
+ makedepends = git
+ makedepends = cmake
+ depends = boost-libs
+ depends = boost
+ depends = doctest
+ depends = minizip
+ depends = pugixml
+ depends = rtmidi
+ depends = alsa-lib
+ depends = nlohmann-json
+ depends = qt5-base
+ depends = qt5-tools
+ optdepends = timidity++: MIDI playback support
+ optdepends = fluidsynth: MIDI playback support
+ provides = powertabeditor
+ conflicts = powertabeditor
+ source = git+https://github.com/powertab/powertabeditor.git
+ sha256sums = SKIP
+
+pkgname = powertabeditor-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..97c57468c345
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Jonas Serych <jonas@sery.ch>
+pkgname='powertabeditor-git'
+pkgver=2.0.0.alpha19.r61.g96550b3
+pkgrel=1
+pkgdesc="Guitar tablature viewer and editor"
+arch=('x86_64')
+url="https://powertab.github.io/"
+license=('GPL-3.0-only')
+depends=('boost-libs' 'boost' 'doctest' 'minizip' 'pugixml' 'rtmidi' 'alsa-lib' 'nlohmann-json' 'qt5-base' 'qt5-tools')
+optdepends=('timidity++: MIDI playback support'
+ 'fluidsynth: MIDI playback support')
+makedepends=('git' 'cmake')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+https://github.com/powertab/powertabeditor.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --long --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cmake -B build -S "${pkgname%-git}" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build
+}
+
+check() {
+ ctest --test-dir build --output-on-failure
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}