summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD29
2 files changed, 27 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 75d9d3c0b8be..cc43a3fe8bbf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Feb 12 16:08:04 UTC 2017
+# Tue Apr 4 18:57:43 UTC 2017
pkgbase = ppsspp-git
pkgdesc = A PSP emulator written in C++
- pkgver = 1.3.r554.9dd3e18ed
+ pkgver = 1.4.r37.e99f1c00f
pkgrel = 1
url = http://www.ppsspp.org/
arch = i686
@@ -21,11 +21,12 @@ pkgbase = ppsspp-git
depends = sdl2
depends = zlib
source = git+https://github.com/hrydgard/ppsspp.git
- source = git+https://github.com/hrydgard/ppsspp-lang.git
- source = ppsspp-glslang::git+https://github.com/hrydgard/glslang.git
source = ppsspp-ffmpeg::git+https://github.com/hrydgard/ppsspp-ffmpeg.git
- source = ppsspp-armips::git+https://github.com/Kingcom/armips.git
+ source = ppsspp-glslang::git+https://github.com/hrydgard/glslang.git
+ source = git+https://github.com/hrydgard/ppsspp-lang.git
+ source = git+https://github.com/Kingcom/armips.git
source = armips-tinyformat::git+https://github.com/Kingcom/tinyformat.git
+ source = git+https://github.com/KhronosGroup/SPIRV-Cross.git
source = ppsspp.desktop
sha256sums = SKIP
sha256sums = SKIP
@@ -33,6 +34,7 @@ pkgbase = ppsspp-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = 1c332702d0aeced07df7e12ba8530bc3f19a52bc76c355f6c84c141becfd46d8
pkgname = ppsspp-git
diff --git a/PKGBUILD b/PKGBUILD
index 1e5f45b87847..fba0170a4b95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgbase=ppsspp-git
pkgname=('ppsspp-git' 'ppsspp-qt-git')
-pkgver=1.3.r554.9dd3e18ed
+pkgver=1.4.r37.e99f1c00f
pkgrel=1
pkgdesc='A PSP emulator written in C++'
arch=('i686' 'x86_64')
@@ -16,11 +16,12 @@ license=('GPL2')
depends=('gcc-libs' 'glew' 'glibc' 'libgl' 'libzip' 'sdl2' 'zlib')
makedepends=('cmake' 'git' 'glu' 'qt5-multimedia' 'qt5-tools')
source=('git+https://github.com/hrydgard/ppsspp.git'
- 'git+https://github.com/hrydgard/ppsspp-lang.git'
- 'ppsspp-glslang::git+https://github.com/hrydgard/glslang.git'
'ppsspp-ffmpeg::git+https://github.com/hrydgard/ppsspp-ffmpeg.git'
- 'ppsspp-armips::git+https://github.com/Kingcom/armips.git'
+ 'ppsspp-glslang::git+https://github.com/hrydgard/glslang.git'
+ 'git+https://github.com/hrydgard/ppsspp-lang.git'
+ 'git+https://github.com/Kingcom/armips.git'
'armips-tinyformat::git+https://github.com/Kingcom/tinyformat.git'
+ 'git+https://github.com/KhronosGroup/SPIRV-Cross.git'
'ppsspp.desktop')
sha256sums=('SKIP'
'SKIP'
@@ -28,6 +29,7 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'1c332702d0aeced07df7e12ba8530bc3f19a52bc76c355f6c84c141becfd46d8')
pkgver() {
@@ -39,16 +41,25 @@ pkgver() {
prepare() {
cd ppsspp
- for submodule in assets/lang ext/{armips,glslang} ffmpeg; do
+ for submodule in ffmpeg assets/lang ext/glslang; do
git submodule init ${submodule}
git config submodule.${submodule}.url ../ppsspp-${submodule#*/}
git submodule update ${submodule}
done
+ for submodule in ext/{SPIRV-Cross,armips}; do
+ git submodule init ${submodule}
+ git config submodule.${submodule}.url ../${submodule#*/}
+ git submodule update ${submodule}
+ done
pushd ext/armips
- git submodule init ext/tinyformat
- git config submodule.ext/tinyformat.url ../../../armips-tinyformat
- git submodule update ext/tinyformat
+
+ for submodule in ext/tinyformat; do
+ git submodule init ${submodule}
+ git config submodule.${submodule}.url ../../../armips-${submodule#*/}
+ git submodule update ${submodule}
+ done
+
popd
for ui in sdl qt; do
@@ -64,7 +75,7 @@ build() {
cmake .. \
-DCMAKE_BUILD_TYPE='Release' \
- -DCMAKE_SKIP_RPATH='ON'
+ -DCMAKE_SKIP_RPATH='ON'
make
cd ../build-qt