summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 22 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c8b6bde3176..eccca1599b0b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = pqiv
pkgdesc = Modern rewrite of Quick Image Viewer
pkgver = 2.11
- pkgrel = 1
- url = https://github.com/phillipberndt/pqiv/
- arch = i686
+ pkgrel = 2
+ url = https://github.com/phillipberndt/pqiv
arch = x86_64
+ arch = i686
license = GPL3
depends = gtk3
- depends = libarchive>=3.3.2
- optdepends = libspectre: PS/EPS support
- optdepends = poppler: PDF support
- optdepends = libwebp: WebP support
- optdepends = imagemagick: additional image formats like PSD
- source = https://github.com/phillipberndt/pqiv/archive/2.11.tar.gz
+ depends = imagemagick
+ depends = libarchive
+ depends = libspectre
+ depends = libwebp
+ depends = poppler
+ source = pqiv-2.11.tar.gz::https://github.com/phillipberndt/pqiv/archive/2.11.tar.gz
sha256sums = ea1f8b6bcb58dee19e2d8168ef4efd01e222c653eabbd3109aad57a870cc8c9b
pkgname = pqiv
diff --git a/PKGBUILD b/PKGBUILD
index dacfb30e74b6..258199cc094c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,24 @@
pkgname=pqiv
pkgver=2.11
-pkgrel=1
-pkgdesc="Modern rewrite of Quick Image Viewer"
-arch=('i686' 'x86_64')
-url="https://github.com/phillipberndt/$pkgname/"
+pkgrel=2
+pkgdesc='Modern rewrite of Quick Image Viewer'
+arch=('x86_64' 'i686')
+url="https://github.com/phillipberndt/$pkgname"
license=('GPL3')
-depends=('gtk3' 'libarchive>=3.3.2')
-optdepends=('libspectre: PS/EPS support'
- 'poppler: PDF support'
- 'libwebp: WebP support'
- 'imagemagick: additional image formats like PSD'
-)
-source=("https://github.com/phillipberndt/$pkgname/archive/$pkgver.tar.gz")
+depends=('ffmpeg'
+ 'gtk3'
+ 'imagemagick'
+ 'libarchive'
+ 'libspectre'
+ 'libwebp'
+ 'poppler-glib')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
sha256sums=('ea1f8b6bcb58dee19e2d8168ef4efd01e222c653eabbd3109aad57a870cc8c9b')
build() {
cd "$pkgname-$pkgver"
- ./configure --backends=archive,gdkpixbuf
+ ./configure
make
}