summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a4c368e169ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = precomp
+ pkgdesc = Recompressor that further compresses already compressed files
+ pkgver = 0.4.6
+ pkgrel = 1
+ url = https://github.com/schnaader/precomp-cpp
+ arch = x86_64
+ license = Apache
+ depends = gcc-libs
+ source = https://github.com/schnaader/precomp-cpp/archive/v0.4.6.tar.gz
+ md5sums = 6a766bdc8e6b065525cb03dbfb8cb4e0
+
+pkgname = precomp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c217bd74da14
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Michael Armbruster <michael at armbrust dot me>
+pkgname=precomp
+_gitname=${pkgname}-cpp
+pkgver=0.4.6
+pkgrel=1
+pkgdesc="Recompressor that further compresses already compressed files"
+arch=('x86_64')
+url="https://github.com/schnaader/precomp-cpp"
+license=('Apache')
+depends=('gcc-libs')
+source=("https://github.com/schnaader/${_gitname}/archive/v${pkgver}.tar.gz")
+md5sums=('6a766bdc8e6b065525cb03dbfb8cb4e0')
+
+build() {
+ cd "${_gitname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${_gitname}-${pkgver}"
+ mkdir -p "${pkgdir}/usr/bin"
+ install -m 0755 precomp "${pkgdir}/usr/bin"
+}