summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
-rw-r--r--rename-bin.patch28
3 files changed, 25 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a3d5424e5d5..5801f274a7c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = prey-node-client
pkgdesc = Node.js client for the Prey anti-theft software
- pkgver = 1.11.1
- pkgrel = 2
+ pkgver = 1.11.2
+ pkgrel = 1
url = https://github.com/prey/prey-node-client
install = prey-node-client.install
arch = x86_64
license = GPL3
- depends = nodejs
+ depends = nodejs>=16.18.0
depends = mpg123
depends = xawtv
depends = scrot
@@ -19,15 +19,15 @@ pkgbase = prey-node-client
depends = gtk3
depends = python-gobject
provides = prey-tracker
- source = prey-node-client-1.11.1.zip::https://github.com/prey/prey-node-client/releases/download/v1.11.1/prey-linux-1.11.1-x64.zip
+ source = prey-node-client-1.11.2.zip::https://github.com/prey/prey-node-client/releases/download/v1.11.2/prey-linux-1.11.2-x64.zip
source = prey-tracker
source = disable-auto-updates.patch
source = rename-bin.patch
source = fix-lock.patch
- sha256sums = 55aa5b7bbe9abb303ec5da9d32c1bafeba91d07df9969a1ce0cac3e9f3a6b461
+ sha256sums = 0a08ace09d6fb5a92f00c968869333f69ac7b854f2c7570dd398982a1d827188
sha256sums = 41f29d334e7671b07cfdc848b2752ccc51710471285e8ebe61c07faa0d36160d
sha256sums = 37094af138edfa0fce31b43025a8b5e56e4a15715b4094e7ae9eea81f44c9e37
- sha256sums = c84e1a1fb5250ac0855f929110854a829269e1ad0a4b33f2779aa9d5f39bcf80
+ sha256sums = 67411d5de07b9b3fece851ed51de43ffdf0beeaabd6b3786f660c7fe8b477ab2
sha256sums = d4df726fb87b652b352ca44ddb78afe0e16e40dc130753d86c2cbfa92ac2781d
pkgname = prey-node-client
diff --git a/PKGBUILD b/PKGBUILD
index f2328431f1cb..1a07345e8be9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
# Co-Maintainer: Serge K <arch@phnx47.net>
pkgname=prey-node-client
-pkgver=1.11.1
-pkgrel=2
+pkgver=1.11.2
+pkgrel=1
pkgdesc="Node.js client for the Prey anti-theft software"
url="https://github.com/prey/prey-node-client"
arch=('x86_64')
license=('GPL3')
-depends=('nodejs' 'mpg123' 'xawtv' 'scrot' 'openssh' 'wireless_tools' 'lsb-release' 'python' 'networkmanager' 'npm' 'gtk3' 'python-gobject')
+depends=('nodejs>=16.18.0' 'mpg123' 'xawtv' 'scrot' 'openssh' 'wireless_tools' 'lsb-release' 'python' 'networkmanager' 'npm' 'gtk3' 'python-gobject')
provides=('prey-tracker')
install="${pkgname}.install"
source=("${pkgname}-${pkgver}.zip::${url}/releases/download/v${pkgver}/prey-linux-${pkgver}-x64.zip"
@@ -16,10 +16,10 @@ source=("${pkgname}-${pkgver}.zip::${url}/releases/download/v${pkgver}/prey-linu
'disable-auto-updates.patch'
'rename-bin.patch'
'fix-lock.patch')
-sha256sums=('55aa5b7bbe9abb303ec5da9d32c1bafeba91d07df9969a1ce0cac3e9f3a6b461'
+sha256sums=('0a08ace09d6fb5a92f00c968869333f69ac7b854f2c7570dd398982a1d827188'
'41f29d334e7671b07cfdc848b2752ccc51710471285e8ebe61c07faa0d36160d'
'37094af138edfa0fce31b43025a8b5e56e4a15715b4094e7ae9eea81f44c9e37'
- 'c84e1a1fb5250ac0855f929110854a829269e1ad0a4b33f2779aa9d5f39bcf80'
+ '67411d5de07b9b3fece851ed51de43ffdf0beeaabd6b3786f660c7fe8b477ab2'
'd4df726fb87b652b352ca44ddb78afe0e16e40dc130753d86c2cbfa92ac2781d')
prepare() {
diff --git a/rename-bin.patch b/rename-bin.patch
index 6b542b374bf7..768543db3e3f 100644
--- a/rename-bin.patch
+++ b/rename-bin.patch
@@ -5,7 +5,7 @@ index 5b5203ca..915abd76 100755
@@ -4,11 +4,11 @@ PATH="$PATH:/usr/local/bin"
dir="$(dirname $0)"
[ -x "$dir/node" ] && node="$dir/node" || node="$(command -v node || command -v nodejs)"
-
+
-# if current file is a symlink (e.g. installed via npm) we'll append
+# if current file is a symlink (e.g. installed via pacman) we'll append
# the relative path to where the package is actually installed.
@@ -14,39 +14,39 @@ index 5b5203ca..915abd76 100755
- dir="$dir/$rel"
+ dir="$rel"
fi
-
+
script="lib/agent/cli.js"
diff --git lib/conf/gui/linux/prey-config.py lib/conf/gui/linux/prey-config.py
index 51b4fc18..859b0191 100755
--- lib/conf/gui/linux/prey-config.py
+++ lib/conf/gui/linux/prey-config.py
@@ -44,7 +44,7 @@ OUT = STDOUT # None
-
+
SCRIPT_PATH = os.sys.path[0]
PACKAGE_PATH = SCRIPT_PATH + '/../../../..'
-PREY_BIN = PACKAGE_PATH + '/bin/prey'
+PREY_BIN = PACKAGE_PATH + '/bin/prey-tracker'
PREY_CONFIG = PREY_BIN + ' config'
-
+
PACKAGE_JSON = open(PACKAGE_PATH + '/package.json', 'r')
diff --git lib/conf/gui/linux/prey-config3.py lib/conf/gui/linux/prey-config3.py
index eec738f6..9815c90a 100755
--- lib/conf/gui/linux/prey-config3.py
+++ lib/conf/gui/linux/prey-config3.py
@@ -44,7 +44,7 @@ OUT = STDOUT # None
-
+
SCRIPT_PATH = os.sys.path[0]
PACKAGE_PATH = SCRIPT_PATH + "/../../../.."
-PREY_BIN = PACKAGE_PATH + "/bin/prey"
+PREY_BIN = PACKAGE_PATH + "/bin/prey-tracker"
PREY_CONFIG = PREY_BIN + " config"
-
+
PACKAGE_JSON = open(PACKAGE_PATH + "/package.json", "r")
diff --git package.json package.json
-index 895f44ec..c502916f 100644
+index 875caeda..f066871f 100644
--- package.json
+++ package.json
-@@ -84,7 +84,7 @@
+@@ -90,7 +90,7 @@
},
"main": "./lib/common",
"bin": {
@@ -55,7 +55,7 @@ index 895f44ec..c502916f 100644
},
"directories": {
"bin": "./bin",
-@@ -93,12 +93,12 @@
+@@ -99,12 +99,12 @@
"test": "./test"
},
"scripts": {
@@ -66,10 +66,10 @@ index 895f44ec..c502916f 100644
"coverage": "istanbul cover _mocha -- lib/agent/plugins test --recursive",
- "postinstall": "./bin/prey config hooks post_install",
- "postupdate": "./bin/prey config hooks post_install",
-- "preuninstall": "./bin/prey config hooks pre_uninstall"
+- "preuninstall": "./bin/prey config hooks pre_uninstall",
+ "postinstall": "./bin/prey-tracker config hooks post_install",
+ "postupdate": "./bin/prey-tracker config hooks post_install",
-+ "preuninstall": "./bin/prey-tracker config hooks pre_uninstall"
- },
- "bugs": {
- "url": "http://github.com/prey/prey-node-client/issues"
++ "preuninstall": "./bin/prey-tracker config hooks pre_uninstall",
+ "lint": "eslint .",
+ "lint-fix": "eslint . --fix",
+ "format": "npx prettier --write"