summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD35
-rw-r--r--disable-auto-updates.patch26
-rw-r--r--rename-bin.patch (renamed from fix-symlink-path-and-disable-auto-updates.patch)41
4 files changed, 54 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f3ed0db5885..1b9f1b3f2d68 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -21,10 +21,12 @@ pkgbase = prey-node-client
depends = python-gobject
provides = prey-tracker
source = prey-tracker
- source = fix-symlink-path-and-disable-auto-updates.patch
+ source = disable-auto-updates.patch
+ source = rename-bin.patch
source = fix-lock.patch
sha256sums = 41f29d334e7671b07cfdc848b2752ccc51710471285e8ebe61c07faa0d36160d
- sha256sums = 0ec04bab461633885aa30ec673322e80c582b2478aab376f938a42fa75500707
+ sha256sums = 37094af138edfa0fce31b43025a8b5e56e4a15715b4094e7ae9eea81f44c9e37
+ sha256sums = c84e1a1fb5250ac0855f929110854a829269e1ad0a4b33f2779aa9d5f39bcf80
sha256sums = d4df726fb87b652b352ca44ddb78afe0e16e40dc130753d86c2cbfa92ac2781d
source_x86_64 = https://downloads.preyproject.com/prey-client-releases/node-client/1.10.11/prey-linux-1.10.11-x64.zip
sha256sums_x86_64 = e0991e83d46290dede40ee2134fda344b8690cf3e5a69df19394d95ae1aa50b6
diff --git a/PKGBUILD b/PKGBUILD
index ba7ea0ff38ff..3ef818ec558a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
# Maintainer: xpt <user.xpt@gmail.com>
-# Contributor: Serge K <arch@phnx47.net>
+# Co-Maintainer: Serge K <arch@phnx47.net>
pkgname=prey-node-client
pkgver=1.10.11
@@ -11,33 +11,32 @@ license=('GPL3')
depends=('nodejs' 'mpg123' 'xawtv' 'scrot' 'openssh' 'wireless_tools' 'lsb-release' 'python' 'networkmanager' 'npm' 'gtk3' 'python-gobject')
provides=('prey-tracker')
install="${pkgname}.install"
-source=('prey-tracker' 'fix-symlink-path-and-disable-auto-updates.patch' 'fix-lock.patch')
+source=('prey-tracker' 'disable-auto-updates.patch' 'rename-bin.patch' 'fix-lock.patch')
source_x86_64=("https://downloads.preyproject.com/prey-client-releases/node-client/${pkgver}/prey-linux-${pkgver}-x64.zip")
source_i686=("https://downloads.preyproject.com/prey-client-releases/node-client/${pkgver}/prey-linux-${pkgver}-x86.zip")
sha256sums=('41f29d334e7671b07cfdc848b2752ccc51710471285e8ebe61c07faa0d36160d'
- '0ec04bab461633885aa30ec673322e80c582b2478aab376f938a42fa75500707'
+ '37094af138edfa0fce31b43025a8b5e56e4a15715b4094e7ae9eea81f44c9e37'
+ 'c84e1a1fb5250ac0855f929110854a829269e1ad0a4b33f2779aa9d5f39bcf80'
'd4df726fb87b652b352ca44ddb78afe0e16e40dc130753d86c2cbfa92ac2781d')
sha256sums_x86_64=('e0991e83d46290dede40ee2134fda344b8690cf3e5a69df19394d95ae1aa50b6')
sha256sums_i686=('21416f91ccebcc1f44927231d2a00606e44113a861b79bd117c6172aa5ede803')
-package() {
- cd "${srcdir}/prey-${pkgver}"
-
- # Fix symlink path, and default-disable automatic updates
- patch -p0 -i ${srcdir}/fix-symlink-path-and-disable-auto-updates.patch
- # Fix broken lock
- patch -p0 -i ${srcdir}/fix-lock.patch
-
- install -dm755 "${pkgdir}/opt/${pkgname}"
- cp -r ./* "${pkgdir}/opt/prey-node-client/"
-
- install -d ${pkgdir}/usr/share/licenses/${pkgname}
- ln -s "/opt/${pkgname}/license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
+prepare() {
+ cd "prey-${pkgver}"
- install -dm755 "${pkgdir}/usr/bin/"
+ patch -p0 -i "${srcdir}/disable-auto-updates.patch"
+ # Rename binary: prey -> prey-tracker
+ patch -p0 -i "${srcdir}/rename-bin.patch"
+ # Fix broken lock: https://github.com/prey/prey-node-client/issues/679
+ patch -p0 -i "${srcdir}/fix-lock.patch"
+}
- # Binary prey named as prey-tracker
+package() {
+ install -dm755 "${pkgdir}/usr/bin"
cp "${srcdir}/prey-tracker" "${pkgdir}/usr/bin/prey-tracker"
+
+ install -dm755 "${pkgdir}/opt/${pkgname}"
+ cp -r "prey-${pkgver}/." "${pkgdir}/opt/prey-node-client"
}
# vim:set ts=2 sw=2 et:
diff --git a/disable-auto-updates.patch b/disable-auto-updates.patch
new file mode 100644
index 000000000000..af368eecb13b
--- /dev/null
+++ b/disable-auto-updates.patch
@@ -0,0 +1,26 @@
+diff --git lib/agent/default.options lib/agent/default.options
+index 8fc81774..c252c554 100644
+--- lib/agent/default.options
++++ lib/agent/default.options
+@@ -9,7 +9,7 @@ plugin_list = control-panel
+ auto_connect = false
+
+ # Allows Prey to auto-update itself when new versions are released.
+-auto_update = true
++auto_update = false
+
+ # Fetch edge releases before they reach the stable branch. No effect without auto_update.
+ download_edge = false
+diff --git prey.conf.default prey.conf.default
+index a3e10203..6b94772c 100644
+--- prey.conf.default
++++ prey.conf.default
+@@ -9,7 +9,7 @@ plugin_list = control-panel
+ auto_connect = false
+
+ # Allows Prey to auto-update itself when new versions are released.
+-auto_update = true
++auto_update = false
+
+ # Fetch edge releases before they reach the stable branch. No effect without auto_update.
+ download_edge = false
diff --git a/fix-symlink-path-and-disable-auto-updates.patch b/rename-bin.patch
index 75e999864ae5..6b542b374bf7 100644
--- a/fix-symlink-path-and-disable-auto-updates.patch
+++ b/rename-bin.patch
@@ -1,4 +1,3 @@
-
diff --git bin/prey bin/prey
index 5b5203ca..915abd76 100755
--- bin/prey
@@ -6,7 +5,7 @@ index 5b5203ca..915abd76 100755
@@ -4,11 +4,11 @@ PATH="$PATH:/usr/local/bin"
dir="$(dirname $0)"
[ -x "$dir/node" ] && node="$dir/node" || node="$(command -v node || command -v nodejs)"
-
+
-# if current file is a symlink (e.g. installed via npm) we'll append
+# if current file is a symlink (e.g. installed via pacman) we'll append
# the relative path to where the package is actually installed.
@@ -15,49 +14,36 @@ index 5b5203ca..915abd76 100755
- dir="$dir/$rel"
+ dir="$rel"
fi
-
+
script="lib/agent/cli.js"
-diff --git lib/agent/default.options lib/agent/default.options
-index 8fc81774..c252c554 100644
---- lib/agent/default.options
-+++ lib/agent/default.options
-@@ -9,7 +9,7 @@ plugin_list = control-panel
- auto_connect = false
-
- # Allows Prey to auto-update itself when new versions are released.
--auto_update = true
-+auto_update = false
-
- # Fetch edge releases before they reach the stable branch. No effect without auto_update.
- download_edge = false
diff --git lib/conf/gui/linux/prey-config.py lib/conf/gui/linux/prey-config.py
index 51b4fc18..859b0191 100755
--- lib/conf/gui/linux/prey-config.py
+++ lib/conf/gui/linux/prey-config.py
@@ -44,7 +44,7 @@ OUT = STDOUT # None
-
+
SCRIPT_PATH = os.sys.path[0]
PACKAGE_PATH = SCRIPT_PATH + '/../../../..'
-PREY_BIN = PACKAGE_PATH + '/bin/prey'
+PREY_BIN = PACKAGE_PATH + '/bin/prey-tracker'
PREY_CONFIG = PREY_BIN + ' config'
-
+
PACKAGE_JSON = open(PACKAGE_PATH + '/package.json', 'r')
diff --git lib/conf/gui/linux/prey-config3.py lib/conf/gui/linux/prey-config3.py
index eec738f6..9815c90a 100755
--- lib/conf/gui/linux/prey-config3.py
+++ lib/conf/gui/linux/prey-config3.py
@@ -44,7 +44,7 @@ OUT = STDOUT # None
-
+
SCRIPT_PATH = os.sys.path[0]
PACKAGE_PATH = SCRIPT_PATH + "/../../../.."
-PREY_BIN = PACKAGE_PATH + "/bin/prey"
+PREY_BIN = PACKAGE_PATH + "/bin/prey-tracker"
PREY_CONFIG = PREY_BIN + " config"
-
+
PACKAGE_JSON = open(PACKAGE_PATH + "/package.json", "r")
diff --git package.json package.json
-index 3ec19613..b1226b3e 100644
+index 895f44ec..c502916f 100644
--- package.json
+++ package.json
@@ -84,7 +84,7 @@
@@ -87,16 +73,3 @@ index 3ec19613..b1226b3e 100644
},
"bugs": {
"url": "http://github.com/prey/prey-node-client/issues"
-diff --git prey.conf.default prey.conf.default
-index a3e10203..6b94772c 100644
---- prey.conf.default
-+++ prey.conf.default
-@@ -9,7 +9,7 @@ plugin_list = control-panel
- auto_connect = false
-
- # Allows Prey to auto-update itself when new versions are released.
--auto_update = true
-+auto_update = false
-
- # Fetch edge releases before they reach the stable branch. No effect without auto_update.
- download_edge = false