summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rwxr-xr-xprime22
3 files changed, 22 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5579c8e3b8e5..0bbb773e02e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = prime
pkgdesc = PRIME Render Offload Launcher. Please visit https://download.nvidia.com/XFree86/Linux-x86_64/435.21/README/primerenderoffload.html to manually configure your Device.
pkgver = 0.1
- pkgrel = 2
+ pkgrel = 3
url = https://download.nvidia.com/XFree86/Linux-x86_64/435.21/README/primerenderoffload.html
arch = any
license = custom
@@ -14,7 +14,7 @@ pkgbase = prime
conflicts = optimus-manager
source = prime
source = 10-nvidia.conf
- md5sums = bacec2275f4b6af8ce291100c3062150
+ md5sums = 4b829fb76d018a9e565eb96a42df4555
md5sums = 9b0995893478ebfe4d26bc3318c18d3e
pkgname = prime
diff --git a/PKGBUILD b/PKGBUILD
index 699a19aa923d..af7105b8405e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=prime
pkgdesc="PRIME Render Offload Launcher. Please visit https://download.nvidia.com/XFree86/Linux-x86_64/435.21/README/primerenderoffload.html to manually configure your Device."
url="https://download.nvidia.com/XFree86/Linux-x86_64/435.21/README/primerenderoffload.html"
pkgver=0.1
-pkgrel=2
+pkgrel=3
arch=(any)
license=("custom")
conflicts=(bumblebee optimus-manager)
@@ -15,7 +15,7 @@ optdepends=(
"lib32-vulkan-intel: for vulkan support")
source=(prime 10-nvidia.conf)
-md5sums=('bacec2275f4b6af8ce291100c3062150'
+md5sums=('4b829fb76d018a9e565eb96a42df4555'
'9b0995893478ebfe4d26bc3318c18d3e')
package()
diff --git a/prime b/prime
index d58bf666678c..9f94065e7265 100755
--- a/prime
+++ b/prime
@@ -3,10 +3,24 @@
case "$@" in
""|"--help"|"-help"|"-h")
cat <<DOC
- This script only launches the command you write after.
- Example:
- prime glxinfo | grep OpenGL
- It should show you video driver in use.
+This script only launches the command you write after.
+Example:
+ prime glxinfo | grep OpenGL
+It should show you video driver in use.
+
+Notice!
+To work this you sould have patched X server. But package xorg-server-git is broken right now.
+You can bulid working Xorg server from PKGBULID on my github: https://github.com/Feresey/xorg-server-git
+
+
+If this does not help, verify that the NVIDIA driver has loaded correctly:
+ grep /var/log/Xorg.0.log -e "EE" -e "WW"
+Also, the xrandr --listproviders command should output as a minimum 2 providers, for example, like this:
+ Providers: number : 2
+ Provider 0: id: 0x29b cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 3 outputs: 2 associated providers: 0 name:modesetting
+ Provider 1: id: 0x277 cap: 0x0 crtcs: 0 outputs: 0 associated providers: 0 name:NVIDIA-G0
+
+If you need help, you can write me on AUR or in telegram @Feresey
DOC
exit 0
;;