summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--10-nvidia.conf42
-rw-r--r--PKGBUILD13
3 files changed, 57 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f056b6b610f1..fb483f5d290d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,17 @@
pkgbase = prime
pkgdesc = PRIME Render Offload Launcher. Please visit https://download.nvidia.com/XFree86/Linux-x86_64/435.21/README/primerenderoffload.html to manually configure your Device.
pkgver = 0.0
- pkgrel = 0
+ pkgrel = 1
url = https://download.nvidia.com/XFree86/Linux-x86_64/435.21/README/primerenderoffload.html
arch = any
depends = bash
+ depends = xorg-server-devel-git
+ conflicts = bumblebee
+ conflicts = optimus-manager
source = prime
+ source = 10-nvidia.conf
md5sums = 6251c4caccc4786c13d253a7803e67ed
+ md5sums = f8a84dde30eb3bfe4b9a61254d741788
pkgname = prime
diff --git a/10-nvidia.conf b/10-nvidia.conf
new file mode 100644
index 000000000000..8cab17141f39
--- /dev/null
+++ b/10-nvidia.conf
@@ -0,0 +1,42 @@
+Section "ServerLayout"
+ Option "AllowNVIDIAGPUScreens"
+ Screen 0 "iGPU" 0 0
+EndSection
+
+# Section "Files"
+# ModulePath "/usr/lib/xorg/modules"
+# ModulePath "/usr/lib/nvidia/xorg"
+# FontPath "/usr/share/fonts/misc"
+# FontPath "/usr/share/fonts/TTF"
+# FontPath "/usr/share/fonts/OTF"
+# FontPath "/usr/share/fonts/Type1"
+# FontPath "/usr/share/fonts/100dpi"
+# FontPath "/usr/share/fonts/75dpi"
+# EndSection
+
+Section "Device"
+ Identifier "iGPU"
+ Driver "modesetting"
+ BusID "PCI:0:2:0"
+EndSection
+
+Section "Device"
+ Identifier "dGPU"
+ Driver "nvidia"
+ BusID "PCI:1:0:0"
+EndSection
+
+Section "Screen"
+ Identifier "iGPU"
+ Device "iGPU"
+ # Monitor "Monitor0"
+ DefaultDepth 24
+ # Option "VSync" "True" # [<bool>]
+ Option "AllowEmptyInitialConfiguration" "True"
+ SubSection "Display"
+ Viewport 0 0
+ Depth 24
+ # Modes "1920x1080"
+ EndSubSection
+EndSection
+
diff --git a/PKGBUILD b/PKGBUILD
index 92ddb5618262..cff3188e9961 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,21 @@ pkgname=prime
pkgdesc="PRIME Render Offload Launcher. Please visit https://download.nvidia.com/XFree86/Linux-x86_64/435.21/README/primerenderoffload.html to manually configure your Device."
url="https://download.nvidia.com/XFree86/Linux-x86_64/435.21/README/primerenderoffload.html"
pkgver=0.0
-pkgrel=0
+pkgrel=1
arch=(any)
license=()
-source=(prime)
-md5sums=('6251c4caccc4786c13d253a7803e67ed')
-depends=(bash)
+conflicts=(bumblebee optimus-manager)
+depends=(bash xorg-server-devel-git)
+
+source=(prime 10-nvidia.conf)
+md5sums=('6251c4caccc4786c13d253a7803e67ed'
+ 'f8a84dde30eb3bfe4b9a61254d741788')
package()
{
mkdir -p "${pkgdir}"/usr/bin/
+ mkdir -p "${pkgdir}"/etc/prime/xorg.conf.d/
install -m a+xr ./prime "${pkgdir}"/usr/bin/
+ cp 10-nvidia.conf "${pkgdir}"/etc/prime/xorg.conf.d/
}