summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
-rw-r--r--config.patch39
3 files changed, 6 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07d501b8256a..d69eb1da5e2c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = privatebin
pkgdesc = a minimalist, open source online pastebin where the server has zero knowledge of pasted data
- pkgver = 1.3.3
+ pkgver = 1.7.1
pkgrel = 1
url = https://privatebin.info
arch = any
@@ -8,10 +8,7 @@ pkgbase = privatebin
depends = php
depends = php-gd
options = emptydirs
- source = privatebin-1.3.3.tar.gz::https://github.com/PrivateBin/PrivateBin/archive/1.3.3.tar.gz
- source = config.patch
- md5sums = 4e1f410c9f527f4d4d03dc98173143e2
- md5sums = 912b477a3d0c7505111bbe17c3901f4a
+ source = privatebin-1.7.1.tar.gz::https://github.com/PrivateBin/PrivateBin/archive/1.7.1.tar.gz
+ md5sums = db62eb947fae29c33c85bb0d642abd20
pkgname = privatebin
-
diff --git a/PKGBUILD b/PKGBUILD
index ae8ce0b8c09a..cfdaf5e203b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=privatebin
-pkgver=1.3.3
+pkgver=1.7.1
pkgrel=1
pkgdesc="a minimalist, open source online pastebin where the server has zero knowledge of pasted data"
url='https://privatebin.info'
@@ -7,15 +7,8 @@ arch=("any")
license=("zlib")
depends=("php" "php-gd")
options=("emptydirs")
-source=("$pkgname-$pkgver.tar.gz::https://github.com/PrivateBin/PrivateBin/archive/$pkgver.tar.gz"
- "config.patch")
-md5sums=('4e1f410c9f527f4d4d03dc98173143e2'
- '912b477a3d0c7505111bbe17c3901f4a')
-
-prepare(){
- cd PrivateBin-$pkgver/cfg
- patch conf.sample.php ../../config.patch
-}
+source=("$pkgname-$pkgver.tar.gz::https://github.com/PrivateBin/PrivateBin/archive/$pkgver.tar.gz")
+md5sums=('db62eb947fae29c33c85bb0d642abd20')
package(){
cd PrivateBin-$pkgver
diff --git a/config.patch b/config.patch
deleted file mode 100644
index 2dd9c8a64b16..000000000000
--- a/config.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-diff --git a/cfg/conf.sample.php b/cfg/conf.sample.php
-index 28dae77..8028191 100644
---- a/cfg/conf.sample.php
-+++ b/cfg/conf.sample.php
-@@ -111,7 +111,7 @@ limit = 10
- ; header = "X_FORWARDED_FOR"
-
- ; directory to store the traffic limits in
--dir = PATH "data"
-+dir = "/var/lib/privatebin/trafficlimits"
-
- [purge]
- ; minimum time limit between two purgings of expired pastes, it is only
-@@ -125,14 +125,14 @@ limit = 300
- batchsize = 10
-
- ; directory to store the purge limit in
--dir = PATH "data"
-+dir = "/var/lib/privatebin/purgelimit"
-
- [model]
- ; name of data model class to load and directory for storage
- ; the default model "Filesystem" stores everything in the filesystem
- class = Filesystem
- [model_options]
--dir = PATH "data"
-+dir = "/var/lib/privatebin/model"
-
- ;[model]
- ; example of DB configuration for MySQL
-@@ -148,7 +148,7 @@ dir = PATH "data"
- ; example of DB configuration for SQLite
- ;class = Database
- ;[model_options]
--;dsn = "sqlite:" PATH "data/db.sq3"
-+;dsn = "sqlite:" "/var/lib/privatebin/data/db.sq3"
- ;usr = null
- ;pwd = null
- ;opt[12] = true ; PDO::ATTR_PERSISTENT