summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
-rw-r--r--no_jdk_download.patch14
3 files changed, 19 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29411c5c072f..7f9386a87c14 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = processing4
pkgdesc = Programming environment for creating images, animations and interactions
- pkgver = 4.0b8
+ pkgver = 4.0.1
pkgrel = 1
url = https://github.com/processing/processing4
arch = x86_64
@@ -15,13 +15,13 @@ pkgbase = processing4
provides = processing4
conflicts = processing
options = !strip
- source = https://github.com/processing/processing4/archive/processing-1283-4.0b8.tar.gz
+ source = https://github.com/processing/processing4/archive/processing-1286-4.0.1.tar.gz
source = disable_update_check.patch
source = no_ffmpeg_download.patch
source = no_jdk_download.patch
- sha256sums = e16c2d5e999119b816ab0f11b1d33dd6a57d48b21051542641fa8485e4a58893
+ sha256sums = 22e4cd253b0db58e2d6cbec64f3765fa76ab6a7d3d7741035421ff8d49e619dd
sha256sums = 35c4538e6e57c0ea296c6cea590cabeb2b0772f9a431838df270dcc581321e30
sha256sums = b0742db84e6a6b148b56df6d4d1e8a3266461fe0f514f703301a310e99f1d126
- sha256sums = 5c3314d6a63955fa472aa87c6c99a9675eed3db9c589b784593c9f14432ef201
+ sha256sums = f8bde916aa0c3c816ba6cc8c22d180001109982f1640f3bff140a57e5100fc64
pkgname = processing4
diff --git a/PKGBUILD b/PKGBUILD
index ace10b4536d2..f4a0a40ac0d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Torben <git at letorbi dot com>
pkgname=processing4
-pkgver=4.0b8
+pkgver=4.0.1
pkgrel=1
arch=(x86_64)
pkgdesc='Programming environment for creating images, animations and interactions'
@@ -12,18 +12,18 @@ conflicts=('processing')
depends=('java-environment-openjdk=17')
makedepends=('ant' 'gendesk' 'rsync' 'unzip')
options=(!strip)
-source=("https://github.com/processing/processing4/archive/processing-$((1275+${pkgver##4.0b}))-$pkgver.tar.gz"
+source=("https://github.com/processing/processing4/archive/processing-$((1285+${pkgver##4.0.}))-$pkgver.tar.gz"
disable_update_check.patch
no_ffmpeg_download.patch
no_jdk_download.patch)
-sha256sums=('e16c2d5e999119b816ab0f11b1d33dd6a57d48b21051542641fa8485e4a58893'
+sha256sums=('22e4cd253b0db58e2d6cbec64f3765fa76ab6a7d3d7741035421ff8d49e619dd'
'35c4538e6e57c0ea296c6cea590cabeb2b0772f9a431838df270dcc581321e30'
'b0742db84e6a6b148b56df6d4d1e8a3266461fe0f514f703301a310e99f1d126'
- '5c3314d6a63955fa472aa87c6c99a9675eed3db9c589b784593c9f14432ef201')
+ 'f8bde916aa0c3c816ba6cc8c22d180001109982f1640f3bff140a57e5100fc64')
prepare() {
# Symbolic link for not having to repeat the revision number
- ln -sf "$pkgname-processing-$((1275+${pkgver##4.0b}))-$pkgver" $pkgname
+ ln -sf "$pkgname-processing-$((1285+${pkgver##4.0.}))-$pkgver" $pkgname
# Create .desktop file
gendesk -f -n --pkgname=processing --pkgdesc="$pkgdesc" --name="Processing" --exec="processing %f" --mimetypes="text/x-processing"
diff --git a/no_jdk_download.patch b/no_jdk_download.patch
index 314c954025b2..dc1b7fcf830f 100644
--- a/no_jdk_download.patch
+++ b/no_jdk_download.patch
@@ -1,6 +1,6 @@
---- a/build/build.xml 2022-01-31 12:44:46.824038995 +0100
-+++ b/build/build.xml 2022-01-31 12:47:21.567810435 +0100
-@@ -940,7 +940,7 @@
+--- a/build/build.xml 2022-08-09 21:02:32.341669755 +0200
++++ b/build/build.xml 2022-08-09 21:13:20.006613526 +0200
+@@ -970,7 +970,7 @@
</if>
</target>
@@ -9,7 +9,7 @@
<mkdir dir="linux/work" />
<copy todir="linux/work" preservelastmodified="true">
-@@ -1014,45 +1014,6 @@
+@@ -1044,51 +1044,6 @@
<copy file="linux/processing-pde.xml" todir="linux/work/lib" />
<copy file="linux/appdata.xml" todir="linux/work/lib" />
<copy file="linux/desktop.template" todir="linux/work/lib" />
@@ -48,6 +48,12 @@
- <fileset refid="jdk-optional-linux" />
- </delete>
-
+- <!-- Throw these 300(!) files into a single zip -->
+- <zip destfile="linux/work/java/legal.zip"
+- basedir="linux/work/java"
+- includes="legal/**" />
+- <delete dir="linux/work/java/legal" />
+-
- <exec executable="rm">
- <arg value="-r"/>
- <arg line="linux/${jdk.folder}"/>