summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD13
-rw-r--r--fix_modules_path.patch9
-rw-r--r--no_downloads.patch43
-rw-r--r--use_system_libraries.patch21
4 files changed, 32 insertions, 54 deletions
diff --git a/PKGBUILD b/PKGBUILD
index da1617a96d97..9e4a07334f80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Torben <git at letorbi dot com>
pkgname=processing4
-pkgver=4.0a4
+pkgver=4.0a5
pkgrel=1
arch=(x86_64)
pkgdesc='Programming environment for creating images, animations and interactions'
@@ -17,16 +17,18 @@ source=("https://github.com/processing/processing4/archive/processing-$((1269+${
change_cmd_name.patch
derive_jdk_from_path.patch
disable_update_check.patch
+ fix_modules_path.patch
no_downloads.patch
use_system_libraries.patch)
-sha256sums=('e3f51f9d755ea8a95d8539af54a029f10e216780af6c18b6a41158aca65e8de9'
+sha256sums=('2b3fe1f5202e00a17afaf9ed0275efaedaa8b26ee74f2f1611e7d466ac951648'
'fabe7420a714f450a6b1430f13fc46f14ba52db57af360365c6a7fd96d0b642f'
'66e87536b740194954670c482d698fc3183995bf48f580078511d50d1a3f0323'
'7f821db61160248b65df19b018dc3b2ba7cc995564dd389bb83b3ce8e5097119'
'fcd5c5ea558ceadde3f840522a5c1cb11e26569aec651e8154194cca39026611'
'35c4538e6e57c0ea296c6cea590cabeb2b0772f9a431838df270dcc581321e30'
- 'a07184b87d3d2ccd35525a0721df787973f92487bae367a0668abd3f64134263'
- 'fbcbb318db352d10ecc03df9a07b199818bb87c9ebdebccdb4a2bbe21a12a370')
+ 'b7c2684fd3fa75d1b6b67457c0e5dd4f86fd9a25e104cdbd5961154e00c9fd72'
+ '532484ea829d6d9f8f13b2197f6b5bc90162bc0068235463b571ddcaa18f2b82'
+ 'ba6d4ae099bcaee3cc23d0af56b9a11d203afaf3c5bf22d3fd935d752c9a32f3')
prepare() {
# Create .desktop file
@@ -41,6 +43,9 @@ prepare() {
# Create missing directories
mkdir -p $pkgname/build/linux/work/java
+
+ # Set correct --module-path in start script (#215)
+ patch $pkgname/build/linux/processing < fix_modules_path.patch
# Don't download any files during Ant's build process
patch $pkgname/build/build.xml < no_downloads.patch
diff --git a/fix_modules_path.patch b/fix_modules_path.patch
new file mode 100644
index 000000000000..4b7325e543a7
--- /dev/null
+++ b/fix_modules_path.patch
@@ -0,0 +1,9 @@
+--- processing.orig 2021-06-24 19:30:03.000000000 +0200
++++ processing 2021-07-05 23:11:53.693278463 +0200
+@@ -113,5 +113,5 @@
+ fi
+ cd "$APPDIR"
+
+- java -splash:lib/about-1x.png -Djna.nosys=true -Djava.library.path=lib:modes/java/libraries/javafx/library/linux64 --module-path=modes/java/libraries/javafx/library/linux64 --add-modules=javafx.base,javafx.controls,javafx.fxml,javafx.graphics,javafx.media,javafx.swing -Xmx512m processing.app.Base "$SKETCH" &
++ java -splash:lib/about-1x.png -Djna.nosys=true -Djava.library.path=lib:modes/java/libraries/javafx/library/linux64 --module-path=modes/java/libraries/javafx/library/linux64/modules --add-modules=javafx.base,javafx.controls,javafx.fxml,javafx.graphics,javafx.media,javafx.swing -Xmx512m processing.app.Base "$SKETCH" &
+ fi
diff --git a/no_downloads.patch b/no_downloads.patch
index 5ae257d2358f..61e195d9ee42 100644
--- a/no_downloads.patch
+++ b/no_downloads.patch
@@ -1,41 +1,15 @@
---- build.xml.orig 2020-06-13 00:09:40.000000000 +0200
-+++ build.xml 2020-06-17 12:46:43.682413239 +0200
-@@ -1009,7 +1009,7 @@
+--- build.xml.orig 2021-06-24 22:24:41.619863591 +0200
++++ build.xml 2021-06-24 22:33:17.284859743 +0200
+@@ -938,7 +938,7 @@
</if>
</target>
-- <target name="linux-build" depends="ignore-tools, check-linux-arm32, check-linux-arm64, revision-check, linux-check-os, jdk-download, jfx-download, subprojects-build, subprojects-build-linux-arm32, subprojects-build-linux-arm64" description="Build Linux version">
+- <target name="linux-build" depends="ignore-tools, check-linux-arm32, check-linux-arm64, revision-check, linux-check-os, jdk-download, subprojects-build, subprojects-build-linux-arm32, subprojects-build-linux-arm64" description="Build Linux version">
+ <target name="linux-build" depends="ignore-tools, check-linux-arm32, check-linux-arm64, revision-check, linux-check-os, subprojects-build, subprojects-build-linux-arm32, subprojects-build-linux-arm64" description="Build Linux version">
<mkdir dir="linux/work" />
<copy todir="linux/work" preservelastmodified="true">
-@@ -1049,25 +1049,6 @@
- <fileset refid="runtime.jars" />
- </copy>
-
-- <preparejfx />
--
-- <!-- Pull in OpenJFX (separated from mainline Java in JDK 11). -->
-- <if>
-- <equals arg1="${jfx.available}" arg2="true" />
-- <then>
-- <copy todir="linux/work/core/library" overwrite="true">
-- <fileset dir="${jfx.path.lib}" includes="*.jar"/>
-- <fileset dir="${jfx.path.lib}" includes="*.so"/>
-- </copy>
--
-- <mkdir dir="linux/work/core/java/legal/openjfx" />
--
-- <copy todir="linux/work/core/java/legal/openjfx" overwrite="true">
-- <fileset dir="${jfx.path.dist}/legal" includes="**"/>
-- </copy>
-- </then>
-- </if>
--
- <copy file="linux/processing" todir="linux/work" />
- <chmod perm="ugo+x" file="linux/work/processing" />
-
-@@ -1094,57 +1075,6 @@
+@@ -1025,54 +1025,6 @@
<copy file="linux/processing-pde.xml" todir="linux/work/lib" />
<copy file="linux/appdata.xml" todir="linux/work/lib" />
<copy file="linux/desktop.template" todir="linux/work/lib" />
@@ -73,10 +47,6 @@
-
- <!-- Remove unused JRE bloat. -->
- <delete failonerror="true">
-- <!--
-- <fileset refid="javafx-basics" />
-- <fileset refid="javafx-linux-${jdk.data.model}" />
-- -->
- <fileset refid="jdk-optional-linux" />
- </delete>
-
@@ -85,11 +55,12 @@
- <arg line="linux/jdk-${jdk.esoteric}+${jdk.build}"/>
- </exec>
-
+- <!--
- <exec executable="rm">
- <arg value="-r"/>
- <arg line="${jfx.path.dist}"/>
- </exec>
--
+- -->
</target>
<target name="linux-run" depends="linux-build"
diff --git a/use_system_libraries.patch b/use_system_libraries.patch
index a1f5752e375b..a2a83b7a2e43 100644
--- a/use_system_libraries.patch
+++ b/use_system_libraries.patch
@@ -1,27 +1,20 @@
---- build_core.xml.orig 2020-06-13 00:09:40.000000000 +0200
-+++ build_core.xml 2020-06-17 15:54:22.945551353 +0200
-@@ -60,15 +60,15 @@
+--- src/processing4/core/build.xml.orig 2021-06-24 22:34:34.389209941 +0200
++++ src/processing4/core/build.xml 2021-06-24 22:38:51.515410408 +0200
+@@ -64,17 +64,6 @@
<path id="classpath.base">
<pathelement location="library/jogl-all.jar" />
<pathelement location="library/gluegen-rt.jar" />
-- <pathelement location="library/javafx-swt.jar" />
+-
+- <!-- <pathelement location="library/javafx-swt.jar" /> -->
- <pathelement location="library/javafx.base.jar" />
- <pathelement location="library/javafx.controls.jar" />
- <pathelement location="library/javafx.fxml.jar" />
- <pathelement location="library/javafx.graphics.jar" />
- <pathelement location="library/javafx.media.jar" />
+- <!-- error? it's not a .jar, but is this how config is handled? [fry 210619] -->
- <pathelement location="library/javafx.properties" />
- <pathelement location="library/javafx.swing.jar" />
-- <pathelement location="library/javafx.web.jar" />
-+ <pathelement location="/usr/lib/jvm/java-11-openjfx/lib/javafx-swt.jar" />
-+ <pathelement location="/usr/lib/jvm/java-11-openjfx/lib/javafx.base.jar" />
-+ <pathelement location="/usr/lib/jvm/java-11-openjfx/lib/javafx.controls.jar" />
-+ <pathelement location="/usr/lib/jvm/java-11-openjfx/lib/javafx.fxml.jar" />
-+ <pathelement location="/usr/lib/jvm/java-11-openjfx/lib/javafx.graphics.jar" />
-+ <pathelement location="/usr/lib/jvm/java-11-openjfx/lib/javafx.media.jar" />
-+ <pathelement location="/usr/lib/jvm/java-11-openjfx/lib/javafx.properties" />
-+ <pathelement location="/usr/lib/jvm/java-11-openjfx/lib/javafx.swing.jar" />
-+ <pathelement location="/usr/lib/jvm/java-11-openjfx/lib/javafx.web.jar" />
+- <!-- <pathelement location="library/javafx.web.jar" /> -->
</path>
<path id="classpath.test">