summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
-rw-r--r--always_use_java-11-openjdk.patch12
-rw-r--r--derive_jdk_from_path.patch11
-rw-r--r--no_downloads.patch66
-rw-r--r--use_system_libraries.patch20
6 files changed, 11 insertions, 154 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f57e1e5cbec6..7fc51caedafa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,33 +1,26 @@
pkgbase = processing4
pkgdesc = Programming environment for creating images, animations and interactions
- pkgver = 4.0a4
+ pkgver = 4.0a5
pkgrel = 1
url = https://github.com/processing/processing4
arch = x86_64
license = GPL
license = LGPL
makedepends = ant
+ makedepends = jdk11-openjdk
makedepends = gendesk
- makedepends = java11-openjfx
makedepends = unzip
- depends = jdk11-openjdk
depends = libgl
options = !strip
- source = https://github.com/processing/processing4/archive/processing-1273-4.0a4.tar.gz
+ source = https://github.com/processing/processing4/archive/processing-1274-4.0a5.tar.gz
source = https://download.processing.org/reference.zip
- source = always_use_java-11-openjdk.patch
source = change_cmd_name.patch
- source = derive_jdk_from_path.patch
source = disable_update_check.patch
- source = no_downloads.patch
- source = use_system_libraries.patch
- sha256sums = e3f51f9d755ea8a95d8539af54a029f10e216780af6c18b6a41158aca65e8de9
+ source = fix_modules_path.patch
+ sha256sums = 2b3fe1f5202e00a17afaf9ed0275efaedaa8b26ee74f2f1611e7d466ac951648
sha256sums = fabe7420a714f450a6b1430f13fc46f14ba52db57af360365c6a7fd96d0b642f
- sha256sums = 66e87536b740194954670c482d698fc3183995bf48f580078511d50d1a3f0323
sha256sums = 7f821db61160248b65df19b018dc3b2ba7cc995564dd389bb83b3ce8e5097119
- sha256sums = fcd5c5ea558ceadde3f840522a5c1cb11e26569aec651e8154194cca39026611
sha256sums = 35c4538e6e57c0ea296c6cea590cabeb2b0772f9a431838df270dcc581321e30
- sha256sums = a07184b87d3d2ccd35525a0721df787973f92487bae367a0668abd3f64134263
- sha256sums = fbcbb318db352d10ecc03df9a07b199818bb87c9ebdebccdb4a2bbe21a12a370
+ sha256sums = b7c2684fd3fa75d1b6b67457c0e5dd4f86fd9a25e104cdbd5961154e00c9fd72
pkgname = processing4
diff --git a/PKGBUILD b/PKGBUILD
index 9e4a07334f80..2dafdc3823ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,28 +7,19 @@ arch=(x86_64)
pkgdesc='Programming environment for creating images, animations and interactions'
url='https://github.com/processing/processing4'
license=(GPL LGPL)
-depends=('jdk11-openjdk' 'libgl')
-# TODO add jogl as make-dependency once a package for version 2.4.0 exists
-makedepends=('ant' 'gendesk' 'java11-openjfx' 'unzip')
+depends=('libgl')
+makedepends=('ant' 'jdk11-openjdk' 'gendesk' 'unzip')
options=(!strip)
source=("https://github.com/processing/processing4/archive/processing-$((1269+${pkgver##4.0a}))-$pkgver.tar.gz"
'https://download.processing.org/reference.zip'
- always_use_java-11-openjdk.patch
change_cmd_name.patch
- derive_jdk_from_path.patch
disable_update_check.patch
- fix_modules_path.patch
- no_downloads.patch
- use_system_libraries.patch)
+ fix_modules_path.patch)
sha256sums=('2b3fe1f5202e00a17afaf9ed0275efaedaa8b26ee74f2f1611e7d466ac951648'
'fabe7420a714f450a6b1430f13fc46f14ba52db57af360365c6a7fd96d0b642f'
- '66e87536b740194954670c482d698fc3183995bf48f580078511d50d1a3f0323'
'7f821db61160248b65df19b018dc3b2ba7cc995564dd389bb83b3ce8e5097119'
- 'fcd5c5ea558ceadde3f840522a5c1cb11e26569aec651e8154194cca39026611'
'35c4538e6e57c0ea296c6cea590cabeb2b0772f9a431838df270dcc581321e30'
- 'b7c2684fd3fa75d1b6b67457c0e5dd4f86fd9a25e104cdbd5961154e00c9fd72'
- '532484ea829d6d9f8f13b2197f6b5bc90162bc0068235463b571ddcaa18f2b82'
- 'ba6d4ae099bcaee3cc23d0af56b9a11d203afaf3c5bf22d3fd935d752c9a32f3')
+ 'b7c2684fd3fa75d1b6b67457c0e5dd4f86fd9a25e104cdbd5961154e00c9fd72')
prepare() {
# Create .desktop file
@@ -47,21 +38,9 @@ prepare() {
# Set correct --module-path in start script (#215)
patch $pkgname/build/linux/processing < fix_modules_path.patch
- # Don't download any files during Ant's build process
- patch $pkgname/build/build.xml < no_downloads.patch
-
- # Use system libraries instead of the ones included in the processing4 repo
- patch $pkgname/core/build.xml < use_system_libraries.patch
-
# Disable update check in default preferences
patch $pkgname/build/shared/lib/defaults.txt < disable_update_check.patch
- # Derive JDK location from java binary found in PATH
- patch $pkgname/build/linux/processing < derive_jdk_from_path.patch
-
- # Always use OpenJDK 11 to run processing
- patch $pkgname/build/linux/processing < always_use_java-11-openjdk.patch
-
# Change command name to 'processing4'
patch $pkgname/build/linux/processing < change_cmd_name.patch
}
@@ -69,7 +48,7 @@ prepare() {
build() {
cd "$pkgname/build"
- PATH="/usr/lib/jvm/java-11-openjdk/bin/:$PATH" ant build
+ ant build
}
package() {
@@ -87,10 +66,4 @@ package() {
# Symbolic links in /usr/bin
ln -s "/usr/share/processing4/processing" "$pkgdir/usr/bin/processing4"
ln -s "/usr/share/processing4/processing-java" "$pkgdir/usr/bin/processing4-java"
-
- # Ensure that processing uses the Java version selected by PATH
- rmdir "$pkgdir/usr/share/processing4/java"
- mkdir -p "$pkgdir/usr/share/processing4/java/bin/"
- echo -e '#!/bin/sh\n`which java` "$@"' > "$pkgdir/usr/share/processing4/java/bin/java"
- chmod a+x "$pkgdir/usr/share/processing4/java/bin/java"
}
diff --git a/always_use_java-11-openjdk.patch b/always_use_java-11-openjdk.patch
deleted file mode 100644
index 722254dcc156..000000000000
--- a/always_use_java-11-openjdk.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/build/linux/processing 2020-01-17 17:20:35.000000000 +0100
-+++ b/build/linux/processing 2020-06-13 14:02:40.924929084 +0200
-@@ -13,6 +13,9 @@
- # Thanks to Ferdinand Kasper for this build script. [fry]
-
-
-+# Always use Oracle's JDK to run processing
-+PATH="/usr/lib/jvm/java-11-openjdk/bin/:$PATH"
-+
- # JARs required from JDK (anywhere in/below the JDK home directory)
- JDKLIBS="rt.jar"
-
diff --git a/derive_jdk_from_path.patch b/derive_jdk_from_path.patch
deleted file mode 100644
index 8e4b11584972..000000000000
--- a/derive_jdk_from_path.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/build/linux/processing 2020-01-17 17:20:35.000000000 +0100
-+++ b/build/linux/processing 2020-06-13 03:21:55.217817070 +0200
-@@ -68,7 +68,7 @@
- log APPDIR
-
- # Try using a local JDK from the same directory as this script
--JDKDIR=`readlink -f "$APPDIR/java"`
-+JDKDIR=`readlink -f $(dirname $(readlink -f $(which java)))/../../`
- make_jdkcp "$JDKDIR"
- log SUCCESS
-
diff --git a/no_downloads.patch b/no_downloads.patch
deleted file mode 100644
index 61e195d9ee42..000000000000
--- a/no_downloads.patch
+++ /dev/null
@@ -1,66 +0,0 @@
---- build.xml.orig 2021-06-24 22:24:41.619863591 +0200
-+++ build.xml 2021-06-24 22:33:17.284859743 +0200
-@@ -938,7 +938,7 @@
- </if>
- </target>
-
-- <target name="linux-build" depends="ignore-tools, check-linux-arm32, check-linux-arm64, revision-check, linux-check-os, jdk-download, subprojects-build, subprojects-build-linux-arm32, subprojects-build-linux-arm64" description="Build Linux version">
-+ <target name="linux-build" depends="ignore-tools, check-linux-arm32, check-linux-arm64, revision-check, linux-check-os, subprojects-build, subprojects-build-linux-arm32, subprojects-build-linux-arm64" description="Build Linux version">
- <mkdir dir="linux/work" />
-
- <copy todir="linux/work" preservelastmodified="true">
-@@ -1025,54 +1025,6 @@
- <copy file="linux/processing-pde.xml" todir="linux/work/lib" />
- <copy file="linux/appdata.xml" todir="linux/work/lib" />
- <copy file="linux/desktop.template" todir="linux/work/lib" />
--
--<!--
-- Cannot use ant version of tar because it doesn't preserve properties.
-- <untar compression="gzip"
-- dest="linux/work"
-- src="linux/jdk.tgz"
-- overwrite="false"/>
---->
--
--<!--
-- http://www.gnu.org/software/tar/manual/html_section/transform.html
---->
-- <exec executable="tar" dir="linux">
-- <!-- Change directory -->
-- <!--
-- <arg value="-C" />
-- <arg value="linux/work" />
-- <arg value="-xzpf" />
-- -->
-- <arg value="xfz" />
-- <arg value="../${jdk.tgz.path}"/>
-- </exec>
--
-- <property name="jdk.dir" value="jdk-${jdk.esoteric}+${jdk.build}/" />
--
-- <exec executable="rsync" dir="linux">
-- <arg value="-a" />
-- <arg value="--delete" />
-- <arg value="${jdk.dir}" />
-- <arg value="work/java/" />
-- </exec>
--
-- <!-- Remove unused JRE bloat. -->
-- <delete failonerror="true">
-- <fileset refid="jdk-optional-linux" />
-- </delete>
--
-- <exec executable="rm">
-- <arg value="-r"/>
-- <arg line="linux/jdk-${jdk.esoteric}+${jdk.build}"/>
-- </exec>
--
-- <!--
-- <exec executable="rm">
-- <arg value="-r"/>
-- <arg line="${jfx.path.dist}"/>
-- </exec>
-- -->
- </target>
-
- <target name="linux-run" depends="linux-build"
diff --git a/use_system_libraries.patch b/use_system_libraries.patch
deleted file mode 100644
index a2a83b7a2e43..000000000000
--- a/use_system_libraries.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/processing4/core/build.xml.orig 2021-06-24 22:34:34.389209941 +0200
-+++ src/processing4/core/build.xml 2021-06-24 22:38:51.515410408 +0200
-@@ -64,17 +64,6 @@
- <path id="classpath.base">
- <pathelement location="library/jogl-all.jar" />
- <pathelement location="library/gluegen-rt.jar" />
--
-- <!-- <pathelement location="library/javafx-swt.jar" /> -->
-- <pathelement location="library/javafx.base.jar" />
-- <pathelement location="library/javafx.controls.jar" />
-- <pathelement location="library/javafx.fxml.jar" />
-- <pathelement location="library/javafx.graphics.jar" />
-- <pathelement location="library/javafx.media.jar" />
-- <!-- error? it's not a .jar, but is this how config is handled? [fry 210619] -->
-- <pathelement location="library/javafx.properties" />
-- <pathelement location="library/javafx.swing.jar" />
-- <!-- <pathelement location="library/javafx.web.jar" /> -->
- </path>
-
- <path id="classpath.test">