summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD29
-rw-r--r--pmos.conf24
-rw-r--r--processmaker-3.2.install34
4 files changed, 111 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b74f3777c143
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = processmaker
+ pkgdesc = Open source web based workflow software and Business Process Management software
+ pkgver = 3.2
+ pkgrel = 1
+ url = https://www.processmaker.com
+ install = processmaker-3.2.install
+ arch = any
+ license = AGPLv3
+ depends = apache
+ depends = mysql55
+ depends = php56
+ depends = php56-apache
+ depends = php56-gd
+ depends = php56-ldap
+ depends = php56-mcrypt
+ noextract = processmaker-3.2-community.tar.gz
+ backup = etc/httpd/conf/extra/pmos.conf
+ source = https://downloads.sourceforge.net/project/processmaker/ProcessMaker/3.2/processmaker-3.2-community.tar.gz
+ source = pmos.conf
+ md5sums = 57caa5f467cfbe87e54c46714ce01e53
+ md5sums = 3d0be1a15ebf8e89b318fea3f4b64ba9
+
+pkgname = processmaker
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..54b20e1eec03
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Ryan Tolboom <Ryan.Tolboom@monroe.k12.nj.us>
+pkgname=processmaker
+pkgver=3.2
+pkgrel=1
+pkgdesc="Open source web based workflow software and Business Process Management software"
+arch=(any)
+url="https://www.processmaker.com"
+license=('AGPLv3')
+depends=(apache mysql55 php56 php56-apache php56-gd php56-ldap php56-mcrypt)
+backup=(etc/httpd/conf/extra/pmos.conf)
+install=${pkgname}-${pkgver}.install
+source=("https://downloads.sourceforge.net/project/${pkgname}/ProcessMaker/${pkgver}/${pkgname}-${pkgver}-community.tar.gz"
+ "pmos.conf")
+noextract=("${pkgname}-${pkgver}-community.tar.gz")
+md5sums=('57caa5f467cfbe87e54c46714ce01e53'
+ '3d0be1a15ebf8e89b318fea3f4b64ba9')
+
+package() {
+ mkdir -p $pkgdir/etc/httpd/conf/extra
+ cp pmos.conf $pkgdir/etc/httpd/conf/extra
+
+ mkdir -p $pkgdir/opt
+ tar -C $pkgdir/opt -zxf ${pkgname}-${pkgver}-community.tar.gz
+ cd $pkgdir/opt/processmaker
+ chmod -R 770 shared workflow/public_html gulliver/js gulliver/thirdparty/html2ps_pdf/cache
+ cd workflow/engine/
+ chmod -R 770 config content/languages plugins xmlform js/labels
+ chown -R http:http $pkgdir/opt/processmaker
+}
diff --git a/pmos.conf b/pmos.conf
new file mode 100644
index 000000000000..4d5111ee8bc1
--- /dev/null
+++ b/pmos.conf
@@ -0,0 +1,24 @@
+#processmaker virtual host
+<VirtualHost your_ip_address >
+
+ ServerName "your_processmaker_domain"
+ DocumentRoot /opt/processmaker/workflow/public_html
+ DirectoryIndex index.html index.php
+
+ <Directory /opt/processmaker/workflow/public_html>
+ Options Indexes FollowSymLinks MultiViews
+ AddDefaultCharset UTF-8
+ AllowOverride All
+ Require all granted
+ ExpiresActive On
+
+ <IfModule mod_rewrite.c>
+ RewriteEngine On
+ RewriteCond %{REQUEST_FILENAME} !-f
+ RewriteRule ^.*/(.*)$ app.php [QSA,L,NC]
+ </IfModule>
+
+ #Deflate filter is optional. It reduces download size, but adds slightly more CPU processing:
+ AddOutputFilterByType DEFLATE text/html
+ </Directory>
+</VirtualHost>
diff --git a/processmaker-3.2.install b/processmaker-3.2.install
new file mode 100644
index 000000000000..415dc56b282e
--- /dev/null
+++ b/processmaker-3.2.install
@@ -0,0 +1,34 @@
+pre_install() {
+
+ cat << EOM
+Edit /etc/httpd/conf/extra/pmos.conf and make sure you add the following
+line to your /etc/httpd/conf/httpd.conf file:
+
+Include conf/extra/pmos.conf
+
+Enable php56 in apache by adding the following line in your
+/etc/httpd/conf/httpd.conf file:
+
+Include conf/extra/php56_module.conf
+
+Also make sure the following modules are enabled in apache: php5_module,
+rewrite_module, expires_module, deflate_module, vhost_alias
+
+Make sure date.timezone is set appropriately in /etc/php56/php.ini and the
+following modules are enabled: curl, gd, ldap, mcrypt, mysql, pdo_mysql,
+and soap.
+
+In the [mysqld] section of /etc/mysql/my.cnf make sure you have the
+following lines:
+
+binlog_format=row
+sql_mode=""
+log_bin_trust_function_creators=1
+
+Otherwise the final query of the installation may fail.
+
+Finally, point your browser to http://localhost to complete your
+installation
+EOM
+
+}