summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--LICENSE28
-rw-r--r--PKGBUILD23
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..924174f20a35
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sat Apr 23 07:59:00 UTC 2016
+pkgbase = programmers-turkish-f
+ pkgdesc = Variant of the Turkish-F layout with symbols and usage adapted from Programmer Dvorak
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/alerque/programmers-turkish-f
+ arch = any
+ license = custom
+ makedepends = coreutils
+ makedepends = programmers-dvorak
+ depends = kbd
+ depends = libxslt
+ source = https://github.com/alerque/programmers-turkish-f/archive/0.0.1.tar.gz
+ source = LICENSE
+ sha256sums = 0a54614e1340ed92d4c6d2bd86cd4213a8c3bd39f1eabb9502d5fe53cef5e4b1
+ sha256sums = 123675c594fe0349a7c27b124cf03715d293af60047d1916c657ac25d0f86ce8
+
+pkgname = programmers-turkish-f
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..74eb0926654c
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,28 @@
+Copyright (c) 1999-2001 Roland Kaufmann. All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions
+are met:
+
+1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+2. Redistributions in binary form must contain the above copyright
+ notice.
+3. Neither the name "Programmer Dvorak" nor the name "Roland Kaufmann"
+ may be used to endorse or promote products derived from this
+ software without specific prior written permission. For written
+ permission, please contact roland@kaufmann.no.
+4. Products derived from this software may not be called "Programmer Dvorak",
+ nor may "Programmer Dvorak" appear in their name, without prior
+ written permission of Roland Kaufmann.
+
+THIS SOFTWARE IS PROVIDED "AS IS" AND ANY EXPRESSED OR IMPLIED WARRANTIES,
+INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND
+FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL ROLAND
+KAUFMANN BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY,
+OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e812c050232
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+pkgname=programmers-turkish-f
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="Variant of the Turkish-F layout with symbols and usage adapted from Programmer Dvorak"
+arch=(any)
+url="https://github.com/alerque/programmers-turkish-f"
+license=('custom')
+depends=('kbd' 'libxslt')
+makedepends=('coreutils' 'programmers-dvorak')
+source=("https://github.com/alerque/${pkgname}/archive/${pkgver}.tar.gz"
+ "LICENSE")
+sha256sums=('0a54614e1340ed92d4c6d2bd86cd4213a8c3bd39f1eabb9502d5fe53cef5e4b1'
+ '123675c594fe0349a7c27b124cf03715d293af60047d1916c657ac25d0f86ce8')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}/linux"
+ XKB_ROOT="${pkgdir}/usr/share/X11/xkb/symbols"
+ install -Dm644 ptf.xkb $XKB_ROOT/ptf
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
+