summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD34
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a5c355896d9d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Wed Apr 12 21:27:40 UTC 2017
+pkgbase = properties-cpp
+ pkgdesc = A very simple convenience library for handling properties and signals in C++11
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://launchpad.net/properties-cpp
+ arch = any
+ license = LGPL3
+ makedepends = cmake
+ source = https://launchpad.net/ubuntu/+archive/primary/+files/properties-cpp_0.0.1+14.10.20140730.orig.tar.gz
+ md5sums = 449f95cc864ebe38a35848885ca1cb4b
+
+pkgname = properties-cpp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f49c5a8c6bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Iwan Timmer <irtimmer@gmail.com>
+
+pkgname=properties-cpp
+pkgdesc="A very simple convenience library for handling properties and signals in C++11"
+pkgver=0.0.1
+_pkgver=0.0.1+14.10.20140730
+pkgrel=1
+arch=('any')
+url="https://launchpad.net/properties-cpp"
+license=('LGPL3')
+makedepends=('cmake')
+source=("https://launchpad.net/ubuntu/+archive/primary/+files/properties-cpp_$_pkgver.orig.tar.gz")
+md5sums=('449f95cc864ebe38a35848885ca1cb4b')
+
+prepare() {
+ cd "$srcdir/${pkgname}-${_pkgver}"
+
+ # Don't build tests
+ truncate -s 0 tests/CMakeLists.txt
+}
+
+build() {
+ mkdir -p "$srcdir/${pkgname}-${_pkgver}/build"
+ cd "$srcdir/${pkgname}-${_pkgver}/build"
+
+ cmake .. -DCMAKE_INSTALL_LIBDIR=/usr/lib -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname}-${_pkgver}/build"
+
+ make DESTDIR="$pkgdir/" install
+}