summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed5f62bc5538..ab7d64a82d39 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = prosody-hg
pkgdesc = Lightweight and extensible Jabber/XMPP server written in Lua (development build from trunk-branch)
- pkgver = r8767+.7738838a013d+
+ pkgver = r9289+.b5fc11475b5d+
pkgrel = 1
url = https://prosody.im/
install = prosody.install
@@ -8,6 +8,7 @@ pkgbase = prosody-hg
arch = x86_64
arch = armv7h
license = MIT
+ checkdepends = luacheck
makedepends = mercurial
depends = lua51
depends = lua51-socket
diff --git a/PKGBUILD b/PKGBUILD
index 0e73d1e9c44f..c1daa01c7272 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=prosody-hg
pkgrel=1
-pkgver=r8767+.7738838a013d+
+pkgver=r9289+.b5fc11475b5d+
pkgver() {
cd "$srcdir/$pkgname"
printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
@@ -21,6 +21,7 @@ license=('MIT')
depends=('lua51' 'lua51-socket' 'lua51-expat' 'lua51-filesystem' 'libidn'
'openssl')
makedepends=('mercurial')
+checkdepends=('luacheck')
conflicts=('prosody')
provides=('prosody')
optdepends=(
@@ -60,6 +61,12 @@ prepare() {
#sed -i 's|sock, err = socket.udp();|sock, err = (socket.udp4 or socket.udp)();|g' net/dns.lua
}
+check() {
+ cd ${pkgname}
+
+ make lint
+}
+
build() {
cd ${pkgname}
./configure --ostype=linux --prefix=/usr --sysconfdir=/etc/prosody \