summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD24
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cb4e1fd72bc5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sat May 27 14:10:39 UTC 2017
+pkgbase = prosody-mod-auth-pam-hg
+ pkgdesc = Authenticate Prosody users against PAM
+ pkgver = tip
+ pkgrel = 1
+ url = https://modules.prosody.im/mod_auth_pam.html
+ arch = any
+ license = MIT
+ makedepends = mercurial
+ depends = prosody>=0.9
+ depends = lua51-pam
+ depends = lua51-posix
+ source = hg+https://hg.prosody.im/prosody-modules/
+ sha1sums = SKIP
+
+pkgname = prosody-mod-auth-pam-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..57267cd32a09
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Yves G. <theYinYeti@yalis.fr>
+
+pkgname=prosody-mod-auth-pam-hg
+pkgver=tip
+pkgrel=1
+pkgdesc="Authenticate Prosody users against PAM"
+arch=('any')
+url="https://modules.prosody.im/mod_auth_pam.html"
+license=('MIT')
+depends=('prosody>=0.9' 'lua51-pam' 'lua51-posix')
+makedepends=('mercurial')
+source=("hg+https://hg.prosody.im/prosody-modules/")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/prosody-modules/"
+ printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+}
+
+package() {
+ cd "${srcdir}/prosody-modules/mod_auth_pam"
+ find . -type f -name '*.lua' -exec install -Dm 644 '{}' "${pkgdir}/usr/lib/prosody/modules/{}" \;
+ find . -type f ! -name '*.lua' -exec install -Dm 644 '{}' "${pkgdir}/usr/share/doc/${pkgname}/{}" \;
+}