summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4126c96ee54e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sat Apr 23 15:22:24 UTC 2016
+pkgbase = prosody-mod-throttle_presence
+ pkgdesc = throttle presence updates in prosody to save power
+ pkgver = r2165.e0b8b8a50013
+ pkgrel = 1
+ url = https://modules.prosody.im/mod_throttle_presence.html
+ arch = any
+ license = MIT
+ makedepends = mercurial
+ depends = prosody
+ source = hg+https://hg.prosody.im/prosody-modules/
+ sha1sums = SKIP
+
+pkgname = prosody-mod-throttle_presence
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a14c89f6b72
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+pkgname=prosody-mod-throttle_presence
+pkgver=r2165.e0b8b8a50013
+pkgrel=1
+pkgdesc="throttle presence updates in prosody to save power"
+arch=('any')
+url="https://modules.prosody.im/mod_throttle_presence.html"
+license=('MIT')
+depends=('prosody')
+makedepends=('mercurial')
+source=("hg+https://hg.prosody.im/prosody-modules/")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/prosody-modules/"
+ printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+}
+
+package() {
+ cd "${srcdir}/prosody-modules/mod_throttle_presence"
+ find . -type f -name '*.lua' -exec install -Dm 644 '{}' "${pkgdir}/usr/lib/prosody/modules/{}" \;
+}