summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD20
2 files changed, 18 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 145af06918bd..8ecee28c5af3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = protobuf-git
pkgdesc = Google's data interchange format
- pkgver = 21.5.r411.gd8421bd49
+ pkgver = 21.12.r1098.gb598b2dd1
pkgrel = 1
url = https://developers.google.com/protocol-buffers/
arch = i686
@@ -9,14 +9,16 @@ pkgbase = protobuf-git
makedepends = git
makedepends = cmake
makedepends = gtest
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
source = git+https://github.com/protocolbuffers/protobuf.git
sha256sums = SKIP
pkgname = protobuf-git
depends = gcc-libs
depends = zlib
- provides = protobuf=21.5.r411.gd8421bd49
+ provides = protobuf=21.12.r1098.gb598b2dd1
provides = libprotoc.so
provides = libprotobuf.so
provides = libprotobuf-lite.so
@@ -24,8 +26,8 @@ pkgname = protobuf-git
pkgname = python-protobuf-git
pkgdesc = Python 3 bindings for Google Protocol Buffers
- depends = protobuf-git=21.5.r411.gd8421bd49
+ depends = protobuf-git=21.12.r1098.gb598b2dd1
depends = python
depends = python-six
- provides = python-protobuf=21.5.r411.gd8421bd49
+ provides = python-protobuf=21.12.r1098.gb598b2dd1
conflicts = python-protobuf
diff --git a/PKGBUILD b/PKGBUILD
index 0479ec75337e..c3e3ee0afab2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgbase=protobuf-git
pkgname=('protobuf-git' 'python-protobuf-git')
-pkgver=21.5.r411.gd8421bd49
+pkgver=21.12.r1098.gb598b2dd1
pkgrel=1
pkgdesc="Google's data interchange format"
arch=('i686' 'x86_64')
url="https://developers.google.com/protocol-buffers/"
license=('BSD')
-makedepends=('git' 'cmake' 'gtest' 'python-setuptools')
+makedepends=('git' 'cmake' 'gtest' 'python-build' 'python-installer' 'python-wheel')
source=("git+https://github.com/protocolbuffers/protobuf.git")
sha256sums=('SKIP')
@@ -41,8 +41,11 @@ build() {
make -C "_build"
cd "python"
- python "setup.py" build \
- --cpp_implementation
+ python \
+ -m build \
+ --wheel \
+ --no-isolation \
+ --config-setting="--cpp_implementation"
}
check() {
@@ -78,9 +81,8 @@ package_python-protobuf-git() {
install -Dm644 "LICENSE" -t "$pkgdir/usr/share/licenses/python-protobuf"
cd "python"
- python "setup.py" install \
- --optimize 1 \
- --skip-build \
- --root "$pkgdir" \
- --cpp_implementation
+ python \
+ -m installer \
+ --destdir="$pkgdir" \
+ dist/*.whl
}