summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD29
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9aed5e0c0dfa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sun Nov 6 10:01:35 UTC 2016
+pkgbase = protobuf-rust-git
+ pkgdesc = Rust Support for Google's protocol buffers
+ pkgver = 1.0.24.511
+ pkgrel = 1
+ url = https://github.com/stepancheg/rust-protobuf
+ arch = x86_64
+ arch = i686
+ license = MIT
+ license = Apache-2.0
+ makedepends = cargo
+ depends = protobuf
+ provides = protobuf-rust
+ conflicts = protobuf-rust
+ source = protobuf-rust-git::git+https://github.com/stepancheg/rust-protobuf.git
+ sha256sums = SKIP
+
+pkgname = protobuf-rust-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42175b3a9ad1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=protobuf-rust-git
+pkgver=1.0.24.511
+pkgrel=1
+pkgdesc="Rust Support for Google's protocol buffers"
+arch=('x86_64' 'i686')
+url="https://github.com/stepancheg/rust-protobuf"
+license=('MIT' 'Apache-2.0')
+depends=('protobuf')
+makedepends=('cargo')
+optdepends=()
+provides=('protobuf-rust')
+conflicts=('protobuf-rust')
+source=($pkgname::git+https://github.com/stepancheg/rust-protobuf.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ echo $(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2).$(git rev-list --count HEAD)
+}
+
+build() {
+ cd $pkgname
+ cargo build --release
+}
+
+package() {
+ cd $pkgname
+ install -D -m755 "$srcdir/$pkgname/target/release/protoc-gen-rust" "$pkgdir/usr/bin/protoc-gen-rust"
+}