summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD22
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4316e2560b82
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = protoc-gen-lisp
+ pkgdesc = A protobuf-compiler plugin for Common Lisp
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/brown/protobuf
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = make
+ depends = protobuf
+ provides = protoc-gen-lisp
+ source = git://github.com/brown/protobuf.git
+ md5sums = SKIP
+
+pkgname = protoc-gen-lisp
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d7a43ee918ec
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/protobuf/
+*.xz
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..867932c4fe7c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# $Id: pkgbuild-mode.el,v 1.23 2007/10/20 16:02:14 juergen Exp $
+# Maintainer: <aaron.l.france@gmail.com>
+pkgname=protoc-gen-lisp
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="A protobuf-compiler plugin for Common Lisp"
+arch=('i686' 'x86_64')
+url="https://github.com/brown/protobuf"
+license=('BSD')
+depends=('protobuf')
+makedepends=('make')
+provides=('protoc-gen-lisp')
+source=(git://github.com/brown/protobuf.git)
+md5sums=(SKIP)
+
+
+package() {
+ cd protobuf/protoc/lisp
+ make INSTALL_ROOT="$pkgdir/usr" install
+}
+
+# vim:set ts=2 sw=2 et: