summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD52
-rw-r--r--ProtocaseDesigner.desktop9
4 files changed, 36 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ff4aa112a44..33f3c7a4aedb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
pkgbase = protocase-designer
pkgdesc = The fastest and easiest way to design, price, and build custom electronics enclosures.
- pkgver = 4.6.13
- pkgrel = 1
+ pkgver = 6.0
+ pkgrel = 2
url = http://www.protocasedesigner.com/
- arch = i686
arch = x86_64
license = custom
depends = java-runtime-common
- depends = jre7-openjdk
- source = https://www.protocasedesigner.com/RELEASE/protocaseDesigner-linux-amd64-4.6.13.tar.gz
+ source = https://www.protocasedesigner.com/RELEASE/ProtocaseDesigner-linux-beta.tar.gz
source = ProtocaseDesigner.desktop
- md5sums = df197d715c974e7ab6b4e125495c1cad
- md5sums = f66d02094444eac61f468371589fcc9c
+ md5sums = SKIP
+ md5sums = SKIP
pkgname = protocase-designer
-
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 94315666b9d5..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,2 +0,0 @@
-*.swp
-protocaseDesigner*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 75846319d934..d84b70803a15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,44 @@
-# Maintainer: Benjamin Denhartog <ben@sudoforge.com>
+# Maintainer: Sick Codes <info@sick.codes>
+# Contributor: Benjamin Denhartog <ben@sudoforge.com>
# Contributor: Wayne Hartmann (DH4) <wayne@bitstorm.pw>
pkgname=protocase-designer
-pkgver=4.6.13
-pkgrel=1
-
+pkgver=6.0
+pkgrel=2
pkgdesc="The fastest and easiest way to design, price, and build custom electronics enclosures."
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://www.protocasedesigner.com/"
-depends=('java-runtime-common' 'jre7-openjdk')
+depends=('java-runtime-common')
#install=protocase-designer.install
license=('custom')
-source=('https://www.protocasedesigner.com/RELEASE/protocaseDesigner-linux-i586-'$pkgver'.tar.gz'
+source=('https://www.protocasedesigner.com/RELEASE/ProtocaseDesigner-linux-beta.tar.gz'
ProtocaseDesigner.desktop)
-md5sums=('876d0202c38fd3fe2573970015927b05'
- 'f66d02094444eac61f468371589fcc9c')
+md5sums=('SKIP'
+ 'SKIP')
-[ "$CARCH" = "x86_64" ] && source=('https://www.protocasedesigner.com/RELEASE/protocaseDesigner-linux-amd64-'$pkgver'.tar.gz'
- ProtocaseDesigner.desktop)
-[ "$CARCH" = "x86_64" ] && md5sums=('df197d715c974e7ab6b4e125495c1cad'
- 'f66d02094444eac61f468371589fcc9c')
-
package() {
-
+ # new version uses a packaged JVM, ready for use
install -d $pkgdir/usr/local/lib/
- cp -R $srcdir/jdesigner/Protocase\ Designer $pkgdir/usr/local/lib
- install -d $pkgdir/usr/local/share/Protocase\ Designer/
- cp -R $srcdir/jdesigner/library $pkgdir/usr/local/share/Protocase\ Designer/
+ install -d $pkgdir/usr/local/bin/
+ install -d $pkgdir/opt/ProtocaseDesigner/
install -d $pkgdir/usr/local/share/pixmaps/
- cp $srcdir/jdesigner/Protocase\ Designer.ico $pkgdir/usr/local/share/pixmaps/ProtocaseDesigner.ico
+ install -d $pkgdir/usr/local/share/applications/
- install -d $pkgdir/usr/local/bin/
+ # copy everything to /opt/ProtocaseDesigner
+ cp -R $srcdir/ProtocaseDesigner $pkgdir/opt/
+
+ # create the shortcut
+ cp $srcdir/ProtocaseDesigner/ProtocaseDesigner.desktop $pkgdir/usr/local/share/applications/ProtocaseDesigner.desktop
+ cp $srcdir/ProtocaseDesigner/Protocase-Designer.png $pkgdir/usr/local/share/pixmaps/Protocase-Designer.png
+
+ # add a shell script to run said files
echo '#/bin/sh' > $pkgdir/usr/local/bin/ProtocaseDesigner
echo "install -d ~/ProtocaseDesigner/" >> $pkgdir/usr/local/bin/ProtocaseDesigner
- echo "mkdir ~/ProtocaseDesigner/UserLibrary" >> $pkgdir/usr/local/bin/ProtocaseDesigner
- echo "LD_LIBRARY_PATH=/usr/local/lib/Protocase\ Designer/:/usr/local/lib/Protocase\ Designer/lib/:\ $LD_LIBRARY_PATH java -jar /usr/local/lib/Protocase\ Designer/jdesigner.jar >> ~/ProtocaseDesigner/error.log 2>&1" >> $pkgdir/usr/local/bin/ProtocaseDesigner
- chmod 755 $pkgdir/usr/local/bin/ProtocaseDesigner
+ echo "mkdir -p ~/ProtocaseDesigner/UserLibrary" >> $pkgdir/usr/local/bin/ProtocaseDesigner
+ echo "LD_LIBRARY_PATH=/opt/ProtocaseDesigner/natives/occjava/linux-x86_64 /opt/ProtocaseDesigner/ProtocaseDesigner" >> $pkgdir/usr/local/bin/ProtocaseDesigner
+ chmod +x $pkgdir/usr/local/bin/ProtocaseDesigner
+
+ # make an alias protocase-designer
+ ln -s $pkgdir/usr/local/bin/ProtocaseDesigner $pkgdir/usr/local/bin/protocase-designer
- install -d $pkgdir/usr/local/share/applications/
- cp $srcdir/ProtocaseDesigner.desktop $pkgdir/usr/local/share/applications/ProtocaseDesigner.desktop
}
diff --git a/ProtocaseDesigner.desktop b/ProtocaseDesigner.desktop
index 5002ada036f3..4ee83b93dd90 100644
--- a/ProtocaseDesigner.desktop
+++ b/ProtocaseDesigner.desktop
@@ -1,10 +1,9 @@
[Desktop Entry]
-Version=1.0
Name=Protocase Designer
-Comment=The fastest and easiest way to design, price, and build custom electronics enclosures.
-Exec=/usr/local/bin/ProtocaseDesigner
-Icon=/usr/local/share/pixmaps/ProtocaseDesigner.ico
+GenericName=Protocase Designer
+Comment=Protocase Designer lets you create custom metal enclosures.
+Exec=/opt/ProtocaseDesigner/ProtocaseDesigner %U
+Icon=/opt/ProtocaseDesigner/ProtocaseDesigner.png
Terminal=false
Type=Application
StartupNotify=true
-Categories=