summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--0002-v45-fixes.patch14
-rw-r--r--PKGBUILD13
-rw-r--r--PKGBUILD.testing8
4 files changed, 34 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4114551a15bc..a1854d789f99 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = proton-ge-custom
pkgdesc = Compatibility tool for Steam Play based on Wine and additional components, GloriousEggroll's custom build
pkgver = GE.Proton7.45
- pkgrel = 1
+ pkgrel = 2
epoch = 2
url = https://github.com/GloriousEggroll/proton-ge-custom
install = proton-ge-custom.install
@@ -248,6 +248,7 @@ pkgbase = proton-ge-custom
source = https://dl.winehq.org/wine/wine-gecko/2.47.3/wine-gecko-2.47.3-x86_64.tar.xz
source = https://github.com/madewokherd/wine-mono/releases/download/wine-mono-7.4.0/wine-mono-7.4.0-x86.tar.xz
source = 0001-AUR-pkgbuild-changes.patch
+ source = 0002-v45-fixes.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
@@ -280,5 +281,6 @@ pkgbase = proton-ge-custom
sha256sums = 0beac419c20ee2e68a1227b6e3fa8d59fec0274ed5e82d0da38613184716ef75
sha256sums = 9249ece664bcf2fecb1308ea1d2542c72923df9fe3df891986f137b2266a9ba3
sha256sums = e0cc0fc3b7d0ab1f168f76c39da226e7a2c8d379fdb9d42369dd2df4397233fb
+ sha256sums = 4182c1456f6d565c6ab7f75a631c81bf7f4fa9c9b35d60b1acbf93cb42616266
pkgname = proton-ge-custom
diff --git a/0002-v45-fixes.patch b/0002-v45-fixes.patch
new file mode 100644
index 000000000000..ab3867292b0b
--- /dev/null
+++ b/0002-v45-fixes.patch
@@ -0,0 +1,14 @@
+diff --git a/patches/protonprep-valve-staging.sh b/patches/protonprep-valve-staging.sh
+index a8031779..b1f3fd73 100755
+--- a/patches/protonprep-valve-staging.sh
++++ b/patches/protonprep-valve-staging.sh
+@@ -396,9 +396,6 @@
+ # https://gitlab.winehq.org/wine/wine/-/merge_requests/1152
+ patch -Np1 < ../patches/wine-hotfixes/pending/4bf9d2403f269e7f3595ad075a4afee9adbda51f.patch
+
+- echo "WINE: -HOTFIX- temp fix for Gears5 hang after logo"
+- patch -Np1 < ../patches/wine-hotfixes/pending/secur32-change.diff
+-
+ ### END WINE HOTFIX SECTION ###
+
+ ### (2-6) WINE PENDING UPSTREAM SECTION ###
diff --git a/PKGBUILD b/PKGBUILD
index 1b3f300b3b30..f698d3ce3cf2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _commit=
pkgver=${_srctag//-/.}
_geckover=2.47.3
_monover=7.4.0
-pkgrel=1
+pkgrel=2
epoch=2
pkgdesc="Compatibility tool for Steam Play based on Wine and additional components, GloriousEggroll's custom build"
url="https://github.com/GloriousEggroll/proton-ge-custom"
@@ -134,6 +134,10 @@ source=(
https://dl.winehq.org/wine/wine-gecko/${_geckover}/wine-gecko-${_geckover}-x86{,_64}.tar.xz
https://github.com/madewokherd/wine-mono/releases/download/wine-mono-${_monover}/wine-mono-${_monover}-x86.tar.xz
0001-AUR-pkgbuild-changes.patch
+ 0002-v45-fixes.patch
+)
+# Optional patches
+source+=(
)
noextract=(
wine-gecko-${_geckover}-{x86,x86_64}.tar.xz
@@ -270,6 +274,7 @@ prepare() {
popd
patch -p1 -i "$srcdir"/0001-AUR-pkgbuild-changes.patch
+ patch -p1 -i "$srcdir"/0002-v45-fixes.patch
# Remove repos from srcdir to save space
for submodule in "${_submodules[@]}"; do
@@ -389,4 +394,8 @@ sha256sums=('SKIP'
'08d318f3dd6440a8a777cf044ccab039b0d9c8809991d2180eb3c9f903135db3'
'0beac419c20ee2e68a1227b6e3fa8d59fec0274ed5e82d0da38613184716ef75'
'9249ece664bcf2fecb1308ea1d2542c72923df9fe3df891986f137b2266a9ba3'
- 'e0cc0fc3b7d0ab1f168f76c39da226e7a2c8d379fdb9d42369dd2df4397233fb')
+ 'e0cc0fc3b7d0ab1f168f76c39da226e7a2c8d379fdb9d42369dd2df4397233fb'
+ '4182c1456f6d565c6ab7f75a631c81bf7f4fa9c9b35d60b1acbf93cb42616266')
+# Optional patches
+sha256sums+=(
+)
diff --git a/PKGBUILD.testing b/PKGBUILD.testing
index 05da4130365e..fcedecbd0dcb 100644
--- a/PKGBUILD.testing
+++ b/PKGBUILD.testing
@@ -6,7 +6,7 @@ _commit=
pkgver=${_srctag//-/.}
_geckover=2.47.3
_monover=7.4.0
-pkgrel=1
+pkgrel=2
epoch=2
pkgdesc="Compatibility tool for Steam Play based on Wine and additional components, GloriousEggroll's custom build"
url="https://github.com/GloriousEggroll/proton-ge-custom"
@@ -134,6 +134,7 @@ source=(
https://dl.winehq.org/wine/wine-gecko/${_geckover}/wine-gecko-${_geckover}-x86{,_64}.tar.xz
https://github.com/madewokherd/wine-mono/releases/download/wine-mono-${_monover}/wine-mono-${_monover}-x86.tar.xz
0001-AUR-pkgbuild-changes.patch
+ 0002-v45-fixes.patch
)
# Optional patches
source+=(
@@ -273,6 +274,7 @@ prepare() {
popd
patch -p1 -i "$srcdir"/0001-AUR-pkgbuild-changes.patch
+ patch -p1 -i "$srcdir"/0002-v45-fixes.patch
# Remove repos from srcdir to save space
for submodule in "${_submodules[@]}"; do
@@ -395,6 +397,8 @@ sha256sums=('SKIP'
'08d318f3dd6440a8a777cf044ccab039b0d9c8809991d2180eb3c9f903135db3'
'0beac419c20ee2e68a1227b6e3fa8d59fec0274ed5e82d0da38613184716ef75'
'9249ece664bcf2fecb1308ea1d2542c72923df9fe3df891986f137b2266a9ba3'
- 'SKIP')
+ 'SKIP'
+ '4182c1456f6d565c6ab7f75a631c81bf7f4fa9c9b35d60b1acbf93cb42616266')
+# Optional patches
sha256sums+=(
)