summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
-rw-r--r--pleasenote.install13
-rw-r--r--supplementary.tar.zstbin15474 -> 4399 bytes
4 files changed, 23 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7fc8cc65f1a4..67e1b3aec118 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,6 +4,7 @@ pkgbase = proton-ge-custom-bin
pkgrel = 1
epoch = 1
url = https://github.com/GloriousEggroll/proton-ge-custom
+ install = pleasenote.install
changelog = changelog.md
arch = x86_64
license = BSD
@@ -27,6 +28,7 @@ pkgbase = proton-ge-custom-bin
depends = lib32-libgudev
depends = lib32-flac
depends = lib32-mpg123
+ depends = lib32-libusb
optdepends = kdialog: KDE splash dialog support
optdepends = zenity: GNOME splash dialog support
optdepends = python-kivy: splash dialog support (big picture mode)
@@ -36,7 +38,6 @@ pkgbase = proton-ge-custom-bin
optdepends = winetricks: protonfixes backend - highly recommended
optdepends = wine: support for 32bit prefixes
optdepends = xboxdrv: gamepad driver service
- optdepends = lib32-libusb: wine usb support
provides = proton
provides = proton-ge-custom=GE.Proton7_14
conflicts = proton-ge-custom
@@ -46,6 +47,6 @@ pkgbase = proton-ge-custom-bin
source = GE-Proton7-14_1.tar.gz::https://github.com/GloriousEggroll/proton-ge-custom/releases/download/GE-Proton7-14/GE-Proton7-14.tar.gz
source = supplementary.tar.zst
sha512sums = 3cbe99a2659dab1871cef0b50deb8cab4f101cc4d0531ed3d2cd7cf89dcee6aa08357b3d485e4260ab7a46af13bf6349daed16deb382cbadd5b2831ba7ad5503
- sha512sums = a484c4cd2003057cf0cbbd32ca5d0106e97c75434e7bef34b35be8239ad98a482358852e41e85abedf5b24ac4d0375c8fffc7deee81a9b08c7799a398f23773b
+ sha512sums = 78f4874746b45151890edede89acc5fef6c6143d93d63db27b592a17f9a3eaa7bcfd25049807f9600794ba1244b121636ebf58ea51a5079e7c7ceef36d0c56a0
pkgname = proton-ge-custom-bin
diff --git a/PKGBUILD b/PKGBUILD
index 6a9c79f42b8b..4899dbc54387 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -36,7 +36,8 @@ depends=('python'
'lib32-libjpeg6-turbo'
'lib32-libgudev'
'lib32-flac'
- 'lib32-mpg123')
+ 'lib32-mpg123'
+ 'lib32-libusb')
optdepends=('kdialog: KDE splash dialog support'
'zenity: GNOME splash dialog support'
'python-kivy: splash dialog support (big picture mode)'
@@ -45,11 +46,11 @@ optdepends=('kdialog: KDE splash dialog support'
'vulkan-driver: driver to be used by dxvk'
'winetricks: protonfixes backend - highly recommended'
'wine: support for 32bit prefixes'
- 'xboxdrv: gamepad driver service'
- 'lib32-libusb: wine usb support')
+ 'xboxdrv: gamepad driver service')
## makepkg options
options=(!strip emptydirs)
+install=pleasenote.install
## fix naming conventions, matching upstream
_pkgname=${pkgname//-bin/}
@@ -70,7 +71,7 @@ url='https://github.com/GloriousEggroll/proton-ge-custom'
source=("${_pkgver}_${pkgrel}.tar.gz::${url}/releases/download/${_pkgver}/${_pkgver}.tar.gz"
'supplementary.tar.zst')
sha512sums=('3cbe99a2659dab1871cef0b50deb8cab4f101cc4d0531ed3d2cd7cf89dcee6aa08357b3d485e4260ab7a46af13bf6349daed16deb382cbadd5b2831ba7ad5503'
- 'a484c4cd2003057cf0cbbd32ca5d0106e97c75434e7bef34b35be8239ad98a482358852e41e85abedf5b24ac4d0375c8fffc7deee81a9b08c7799a398f23773b')
+ '78f4874746b45151890edede89acc5fef6c6143d93d63db27b592a17f9a3eaa7bcfd25049807f9600794ba1244b121636ebf58ea51a5079e7c7ceef36d0c56a0')
build() {
## patches
@@ -88,6 +89,7 @@ package() {
install -d "${pkgdir}/${_protondir}/"
install -d "${pkgdir}/${_licensedir}/"
install -d "${pkgdir}/$(dirname ${_execfile})/"
+ install -d "${pkgdir}/etc/security/limits.d/"
## licenses
mv "${_srcdir}/LICENSE" "${pkgdir}/${_licensedir}/license"
mv "${_srcdir}/LICENSE.OFL" "${pkgdir}/${_licensedir}/license_OFL"
@@ -95,6 +97,7 @@ package() {
mv "${_srcdir}/protonfixes/LICENSE" "${pkgdir}/${_licensedir}/license_protonfixes"
## config files
install --mode=0775 --group=50 "${srcdir}"/configs/user_settings.py "${pkgdir}/${_protoncfg}"
+ install --mode=0644 "${srcdir}"/configs/limits.conf "${pkgdir}"/etc/security/limits.d/10-games.conf
## executables
mv "${_srcdir}"/* "${pkgdir}/${_protondir}"
install --mode=0755 "${srcdir}"/launchers/proton.sh "${pkgdir}/${_execfile}"
diff --git a/pleasenote.install b/pleasenote.install
new file mode 100644
index 000000000000..fe826051a742
--- /dev/null
+++ b/pleasenote.install
@@ -0,0 +1,13 @@
+post_install() {
+ ## Wine wants to adjust niceness of a process up to -10. It will complain if RLIMIT_NICE will not allow this.
+ ## Since niceness is limited to 0 by default on arch, we make this work with pam login by setting nice limit to -10 for users in group games.
+ ## See file /etc/security/limits.d/10-games.conf.
+ echo ""
+ echo "The wine executable used by proton can automatically set the niceness of a process;"
+ echo "Consider adding yourself to the games group to make this work by issuing: usermod -a -G games"
+ echo ""
+}
+
+post_upgrade() {
+ post_install
+} \ No newline at end of file
diff --git a/supplementary.tar.zst b/supplementary.tar.zst
index 870a8ea4d1ff..9e49c9d24d3a 100644
--- a/supplementary.tar.zst
+++ b/supplementary.tar.zst
Binary files differ