summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD27
2 files changed, 33 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c96e8ac1ea5..f45bb5247c4e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = protonplus
pkgdesc = A simple proton version manager
pkgver = 0.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Vysp3r/ProtonPlus
arch = x86_64
license = GPL3
@@ -13,6 +13,14 @@ pkgbase = protonplus
depends = libarchive
depends = libsoup3
source = protonplus-0.3.0.tar.gz::https://github.com/Vysp3r/ProtonPlus/archive/refs/tags/v0.3.0.tar.gz
+ source = https://github.com/Vysp3r/ProtonPlus/commit/b079df4ff9c793ded8967c8a930a1bb49c652bd4.patch
+ source = https://github.com/Vysp3r/ProtonPlus/commit/a0147ff163a4df77d4461ba17927c54baf107bb7.patch
+ source = https://github.com/Vysp3r/ProtonPlus/commit/c22ff10dc56b69cdff203020fcb7417e128778ca.patch
+ source = https://github.com/Vysp3r/ProtonPlus/commit/2a75650332f842f09a3d3bd39f397ff9e6f28956.patch
sha256sums = b09ff0015111bcd895f7bae74cb04e7dc931bda22fe7ae62b852fec1a72ddd2c
+ sha256sums = b9934fa7a054ced1575b598377b6b29835001af3fb11eab44bd380bf3b525fa1
+ sha256sums = 974e898e7ca14ae92f3eea59d332e72b5cac8ded6ab95f46b37078fff38be3c3
+ sha256sums = a2753a167e367fa45bc11cea82617df2322ed1e2a0320fa4ad313d22b23a52dc
+ sha256sums = 2b4882d407d7b78502ae814e8b8e6fa9b4234f682340f7f63bbc5ca04a843897
pkgname = protonplus
diff --git a/PKGBUILD b/PKGBUILD
index 7b4dbaef8719..2619a550455e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=protonplus
pkgver=0.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="A simple proton version manager"
arch=('x86_64')
url="https://github.com/Vysp3r/ProtonPlus"
@@ -9,14 +9,35 @@ license=('GPL3')
depends=('json-glib' 'libadwaita' 'libarchive' 'libsoup3')
makedepends=('meson' 'vala')
checkdepends=('appstream-glib')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('b09ff0015111bcd895f7bae74cb04e7dc931bda22fe7ae62b852fec1a72ddd2c')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz"
+ 'https://github.com/Vysp3r/ProtonPlus/commit/b079df4ff9c793ded8967c8a930a1bb49c652bd4.patch'
+ 'https://github.com/Vysp3r/ProtonPlus/commit/a0147ff163a4df77d4461ba17927c54baf107bb7.patch'
+ 'https://github.com/Vysp3r/ProtonPlus/commit/c22ff10dc56b69cdff203020fcb7417e128778ca.patch'
+ 'https://github.com/Vysp3r/ProtonPlus/commit/2a75650332f842f09a3d3bd39f397ff9e6f28956.patch')
+sha256sums=('b09ff0015111bcd895f7bae74cb04e7dc931bda22fe7ae62b852fec1a72ddd2c'
+ 'b9934fa7a054ced1575b598377b6b29835001af3fb11eab44bd380bf3b525fa1'
+ '974e898e7ca14ae92f3eea59d332e72b5cac8ded6ab95f46b37078fff38be3c3'
+ 'a2753a167e367fa45bc11cea82617df2322ed1e2a0320fa4ad313d22b23a52dc'
+ '2b4882d407d7b78502ae814e8b8e6fa9b4234f682340f7f63bbc5ca04a843897')
prepare() {
cd "ProtonPlus-$pkgver"
# Correct desktop file category
+ # https://github.com/Vysp3r/ProtonPlus/pull/39
sed -i 's/Games;/Game;/g' data/com.vysp3r.ProtonPlus.desktop
+
+ # Fix tool installation
+ patch -Np1 -i ../b079df4ff9c793ded8967c8a930a1bb49c652bd4.patch
+
+ # Test to fix installer
+ patch -Np1 -i ../a0147ff163a4df77d4461ba17927c54baf107bb7.patch
+
+ # Fix installed tools finder
+ patch -Np1 -i ../c22ff10dc56b69cdff203020fcb7417e128778ca.patch
+
+ # Fix installed tools not showing up properly
+ patch -Np1 -i ../2a75650332f842f09a3d3bd39f397ff9e6f28956.patch
}
build() {