summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..44f3b984533d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = protontricks-git
+ pkgdesc = A simple wrapper that does winetricks things for Proton enabled games.
+ pkgver = 0.r14.c219cd2
+ pkgrel = 1
+ url = https://github.com/Sirmentio/protontricks
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python
+ depends = winetricks
+ source = git+https://github.com/Sirmentio/protontricks.git
+ sha256sums = SKIP
+
+pkgname = protontricks-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..193aafd16d02
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jason Stryker <inbox at jasonstryker dot com>
+
+pkgname=protontricks-git
+pkgver=0.r14.c219cd2
+pkgrel=1
+pkgdesc="A simple wrapper that does winetricks things for Proton enabled games."
+arch=('any')
+url="https://github.com/Sirmentio/protontricks"
+license=('GPL3')
+depends=('python' 'winetricks')
+makedepends=('git')
+source=("git+https://github.com/Sirmentio/protontricks.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd protontricks
+ printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd protontricks
+
+ install -D -m 0755 protontricks "${pkgdir}/usr/bin/protontricks"
+
+ install -D -m 0644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+}
+
+# vim:set ts=2 sw=2 et: