summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD44
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..88b08466b166
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Wed Dec 30 01:07:13 UTC 2015
+pkgbase = prototypical
+ pkgdesc = A\ starting\ point\ for\ a\ project
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/vinsonchuong/prototypical
+ arch = any
+ license = MIT
+ checkdepends = bats-git
+ makedepends = clidoc
+ depends = bash-common-parse-options
+ depends = perl
+ depends = ruby
+ depends = nodejs
+ depends = npm
+ optdepends = hub
+ source = https://github.com/vinsonchuong/prototypical/archive/v0.0.1-1.tar.gz
+ md5sums = 2aca29684ffc14c17bd5eac6fb2cefe2
+
+pkgname = prototypical
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9aeac58d23cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Vinson Chuong <vinsonchuong@gmail.com>
+pkgname="prototypical"
+pkgver="0.0.1"
+pkgrel="1"
+pkgdesc="A\ starting\ point\ for\ a\ project"
+arch=("any")
+url="https://github.com/vinsonchuong/prototypical"
+license=("MIT")
+depends=(
+ "bash-common-parse-options"
+ "perl"
+ "ruby"
+ "nodejs"
+ "npm"
+)
+optdepends=("hub")
+makedepends=("clidoc")
+checkdepends=("bats-git")
+source=("https://github.com/vinsonchuong/prototypical/archive/v0.0.1-1.tar.gz")
+md5sums=('2aca29684ffc14c17bd5eac6fb2cefe2')
+build ()
+{
+ cd "${srcdir}/${pkgname}-${pkgver}-${pkgrel}";
+ if [ -d 'doc' ]; then
+ clidoc doc/*.md;
+ fi
+}
+check ()
+{
+ cd "${srcdir}/${pkgname}-${pkgver}-${pkgrel}";
+ if [ -d 'spec' ]; then
+ bats spec;
+ fi
+}
+package ()
+{
+ cd "${srcdir}/${pkgname}-${pkgver}-${pkgrel}";
+ [ -d 'bin' ] && install -Dm755 -t "${pkgdir}/usr/bin" bin/*;
+ [ -d 'help' ] && install -Dm644 -t "${pkgdir}/usr/share/${pkgname}/help" help/*;
+ [ -f 'README.md' ] && install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" 'README.md';
+ [ -d 'doc' ] && install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}/doc" doc/*.md;
+ [ -f 'LICENSE' ] && install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" 'LICENSE';
+ [ -d 'man' ] && install -Dm644 -t "${pkgdir}/usr/share/man/man1" man/*
+}