summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD26
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3ecd66a43174
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = proxy-ns
+ pkgdesc = Run programs in a network namespace where all traffic go through proxy
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/OkamiW/proxy-ns
+ arch = x86_64
+ license = GPL
+ makedepends = make
+ depends = bash
+ depends = glibc
+ depends = libcap
+ depends = iproute2
+ depends = badvpn-git
+ backup = etc/default/proxy-nsd.conf
+ source = git+https://github.com/OkamiW/proxy-ns
+ sha512sums = SKIP
+
+pkgname = proxy-ns
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..924dfb95c209
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2299baf61fd7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: ookami <mail@ookami.one>
+pkgname=proxy-ns
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Run programs in a network namespace where all traffic go through proxy"
+arch=('x86_64')
+url="https://github.com/OkamiW/proxy-ns"
+license=('GPL')
+depends=('bash' 'glibc' 'libcap' 'iproute2' 'badvpn-git')
+makedepends=('make')
+source=("git+$url")
+sha512sums=('SKIP')
+backup=(
+ etc/default/proxy-nsd.conf
+)
+
+build() {
+ cd "$srcdir/$pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+ setcap cap_sys_admin=ep $pkgdir/usr/bin/proxy-ns
+}