summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c37aa1a9ae8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ps2emu-git
+ pkgdesc = PS/2 emulation tools for recording and playing back PS/2 devices
+ pkgver = v0.1.r39.gf04ff09
+ pkgrel = 1
+ url = https://github.com/lyude/ps2emu
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ provides = ps2emu
+ conflicts = ps2emu
+ source = ps2emu::git+https://github.com/Lyude/ps2emu.git#branch=master
+ sha512sums = SKIP
+
+pkgname = ps2emu-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d27b318e748
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+_pkgname=ps2emu
+pkgname=${_pkgname}-git
+pkgver=v0.1.r39.gf04ff09
+pkgrel=1
+pkgdesc='PS/2 emulation tools for recording and playing back PS/2 devices'
+arch=('i686' 'x86_64')
+url='https://github.com/lyude/ps2emu'
+license=('GPL2')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git+https://github.com/Lyude/ps2emu.git#branch=master")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${_pkgname}"
+ ./autogen.sh --prefix=/usr --sbindir=/usr/bin
+ make
+}
+
+package() {
+ cd "${_pkgname}"
+ make DESTDIR="$pkgdir" install
+}