summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rwxr-xr-xexecutable3
3 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c3e3024c1d7..925d4066c423 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pseucoco
pkgdesc = A Pseuco compiler written in Java
pkgver = 2.3
- pkgrel = 2
+ pkgrel = 3
url = https://liebe.cs.uni-saarland.de/gitlab/pseuco/pseuco-java-compiler
install = pseucoco.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index c2d3e2752702..71739fe5c302 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=pseucoco
pkgname="${_pkgname}"
pkgver=2.3
-pkgrel=2
+pkgrel=3
pkgdesc="A Pseuco compiler written in Java"
arch=("i686" "x86_64")
url="https://liebe.cs.uni-saarland.de/gitlab/pseuco/pseuco-java-compiler"
diff --git a/executable b/executable
index 92295695e42a..87f9d498f494 100755
--- a/executable
+++ b/executable
@@ -26,7 +26,8 @@ else
else
if [[ -e $1 ]]
then
- pseucoco -i $1
+ cat $1 | sed '/^#!/d' > /tmp/pseucotmp
+ pseucoco -i /tmp/pseucotmp
else
echo "Error: File \"$1\" not found."
fi