summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
-rw-r--r--no-qca-qt4.patch36
3 files changed, 50 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bcca31ca8a3c..76ae3d9e672b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = psi-plus-git
pkgdesc = Psi+ is a powerful Jabber client (Qt, C++) designed for the Jabber power users (built with Qt 5.x)
- pkgver = 1.2.151.0.g88ba25a7
+ pkgver = 1.2.153.0.gb166f4ab
pkgrel = 1
url = http://psi-plus.com
arch = i686
@@ -10,7 +10,6 @@ pkgbase = psi-plus-git
makedepends = patch
makedepends = qconf-git
makedepends = cmake
- makedepends = qca-qt4
depends = qt5-base
depends = qt5-webkit
depends = qt5-multimedia
@@ -21,8 +20,8 @@ pkgbase = psi-plus-git
depends = libxss
depends = qt5-svg
depends = hunspell
- provides = psi-plus=1.2.151.0.g88ba25a7
- provides = psi-plus-qt5-git=1.2.151.0.g88ba25a7
+ provides = psi-plus=1.2.153.0.gb166f4ab
+ provides = psi-plus-qt5-git=1.2.153.0.gb166f4ab
conflicts = psi-plus
conflicts = psi-plus-qt5-git
conflicts = psi-plus-webkit-qt5-git
@@ -31,10 +30,12 @@ pkgbase = psi-plus-git
source = git://github.com/psi-plus/main.git
source = conf.diff
source = join.patch
+ source = no-qca-qt4.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = 690770c7c8976d536d8c4078d01c28f187f510574ddffe91251f5045fa672e53
sha256sums = ea25a58c7efe25979b8d257598608187380e8f35ace25e96cab9c357dcdbc974
+ sha256sums = a6ea9a62100b6990b8a6c8590a6d0e9df095b99b6527bb5490a7fd3f6929ac23
pkgname = psi-plus-git
diff --git a/PKGBUILD b/PKGBUILD
index ff0c52fc0535..f026fb6adf7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Alexey D. <lq07829icatm@rambler.ru>
pkgname=psi-plus-git
-pkgver=1.2.151.0.g88ba25a7
+pkgver=1.2.153.0.gb166f4ab
pkgrel=1
pkgdesc="Psi+ is a powerful Jabber client (Qt, C++) designed for the Jabber power users (built with Qt 5.x)"
url="http://psi-plus.com"
@@ -12,17 +12,19 @@ license=('GPL2')
arch=('i686' 'x86_64')
depends=('qt5-base' 'qt5-webkit' 'qt5-multimedia' 'qt5-x11extras' 'qca-qt5'
'libidn' 'aspell' 'libxss' 'qt5-svg' 'hunspell')
-makedepends=('git' 'patch' 'qconf-git' 'cmake' 'qca-qt4')
+makedepends=('git' 'patch' 'qconf-git' 'cmake')
provides=("psi-plus=$pkgver" "psi-plus-qt5-git=$pkgver")
conflicts=('psi-plus' 'psi-plus-qt5-git' 'psi-plus-webkit-qt5-git' 'psi-plus-webkit-git')
source=("git://github.com/psi-plus/psi-plus-snapshots"
"git://github.com/psi-plus/main.git"
'conf.diff'
- 'join.patch')
+ 'join.patch'
+ 'no-qca-qt4.patch')
sha256sums=('SKIP'
'SKIP'
'690770c7c8976d536d8c4078d01c28f187f510574ddffe91251f5045fa672e53'
- 'ea25a58c7efe25979b8d257598608187380e8f35ace25e96cab9c357dcdbc974')
+ 'ea25a58c7efe25979b8d257598608187380e8f35ace25e96cab9c357dcdbc974'
+ 'a6ea9a62100b6990b8a6c8590a6d0e9df095b99b6527bb5490a7fd3f6929ac23')
pkgver() {
@@ -38,7 +40,9 @@ prepare() {
# cp -r "$srcdir"/main/iconsets/* ./iconsets
# echo "$pkgver ($(date +"%Y-%m-%d"))" >version
patch -p1 <"$srcdir"/join.patch
-}
+ patch -Np1 -i "${srcdir}//no-qca-qt4.patch"
+ }
+
build() {
cd psi-plus-snapshots
diff --git a/no-qca-qt4.patch b/no-qca-qt4.patch
new file mode 100644
index 000000000000..15a5c6129bc3
--- /dev/null
+++ b/no-qca-qt4.patch
@@ -0,0 +1,36 @@
+From f3372d84595d10b757de4568399707bc721f6850 Mon Sep 17 00:00:00 2001
+From: sirlucjan <lucjan.lucjanov@gmail.com>
+Date: Sun, 7 Jan 2018 21:04:37 +0100
+Subject: [PATCH] Update cmakelist.txt
+
+---
+ iris/CMakeLists.txt | 2 +-
+ src/CMakeLists.txt | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/iris/CMakeLists.txt b/iris/CMakeLists.txt
+index 50228489..85dcec60 100644
+--- a/iris/CMakeLists.txt
++++ b/iris/CMakeLists.txt
+@@ -39,7 +39,7 @@ if(USE_QJDNS)
+ add_definitions(-DNEED_JDNS)
+ endif()
+
+-find_package(Qca REQUIRED)
++find_package(Qca-qt5 REQUIRED)
+ set(QCA_INCLUDES ${Qca_INCLUDE_DIR})
+ set(qca_LIB ${Qca_LIBRARY})
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 1f78cd05..57c73c4c 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -73,7 +73,7 @@ if(APPLE)
+ list(APPEND EXTRA_LDFLAGS ${SPARKLE_LIBRARY} "-framework Carbon" "-framework AppKit" "-framework IOKit" "-framework CoreAudio" "-framework AudioToolbox")
+ endif()
+
+-find_package( Qca REQUIRED )
++find_package( Qca-qt5 REQUIRED )
+
+ if(LINUX)
+ find_package(X11 REQUIRED)