summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b36003dd67ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = psp-libtremor
+ pkgdesc = Integer-only, fully Ogg Vorbis compliant software decoder library (psp)
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = http://www.xiph.org/vorbis/
+ arch = any
+ groups = psp
+ license = BSD
+ makedepends = psp-gcc
+ depends = psp-sdk
+ options = !buildflags
+ options = !strip
+ options = staticlibs
+ source = git+https://github.com/pspdev/psp-ports.git
+ md5sums = SKIP
+
+pkgname = psp-libtremor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3fe50b7c3132
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: xantares <xantares09 at hotmail dot com>
+
+pkgname=psp-libtremor
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="Integer-only, fully Ogg Vorbis compliant software decoder library (psp)"
+arch=(any)
+url="http://www.xiph.org/vorbis/"
+license=('BSD')
+groups=('psp')
+depends=('psp-sdk')
+makedepends=('psp-gcc')
+options=('!buildflags' '!strip' 'staticlibs')
+source=("git+https://github.com/pspdev/psp-ports.git")
+md5sums=('SKIP')
+
+
+build()
+{
+ cd "$srcdir/psp-ports/libTremor"
+ sh autogen.sh
+ make distclean # autogen calls configure
+ export LDFLAGS="-L$(psp-config --pspsdk-path)/lib -L$(psp-config --psp-prefix)/lib -lc -lpspuser"
+ export LIBS="-lc -lpspuser"
+ mkdir -p build-psp && pushd build-psp
+ ../configure --prefix=/usr/psp --host=psp
+ make
+}
+
+package()
+{
+ cd "$srcdir/psp-ports/libTremor/build-psp"
+ make install DESTDIR="$pkgdir"
+}
+