summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e3016c7d0faa..605897801bb1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = psst-git
pkgdesc = Fast and multi-platform Spotify client with native GUI
- pkgver = r213.4ee0b48
- pkgrel = 1
+ pkgver = r264.1d5cf32
+ pkgrel = 2
url = https://github.com/jpochyla/psst
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index bc059c18f3a9..2b741c76b7dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=psst-git
_pkgname="psst"
-pkgver=r213.4ee0b48
-pkgrel=1
+pkgver=r264.1d5cf32
+pkgrel=2
pkgdesc="Fast and multi-platform Spotify client with native GUI"
arch=("x86_64")
url="https://github.com/jpochyla/psst"
@@ -30,16 +30,20 @@ pkgver() {
prepare() {
cd "$_pkgname"
git submodule update --recursive --init
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
}
build() {
cd "$_pkgname"
- cargo build --release
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
}
check() {
cd "$_pkgname"
- cargo test --release
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen --all-features
}
package() {