summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--010-pstoedit-fix-plain-c.patch41
-rw-r--r--020-pstoedit-fix-pkgconfig-includedir.patch17
-rw-r--r--PKGBUILD15
4 files changed, 77 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ea29f32f7e9..aac69aa74a68 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pstoedit-nomagick
pkgdesc = Translates PS/PDF graphics to other vector formats (no ImageMagick dependency)
- pkgver = 3.78
+ pkgver = 4.00
pkgrel = 1
url = http://www.pstoedit.net/
arch = x86_64
@@ -14,7 +14,11 @@ pkgbase = pstoedit-nomagick
depends = zlib
provides = pstoedit
conflicts = pstoedit
- source = https://sourceforge.net/projects/pstoedit/files/pstoedit/3.78/pstoedit-3.78.tar.gz
- sha256sums = 8cc28e34bc7f88d913780f8074e813dd5aaa0ac2056a6b36d4bf004a0e90d801
+ source = https://sourceforge.net/projects/pstoedit/files/pstoedit/4.00/pstoedit-4.00.tar.gz
+ source = 010-pstoedit-fix-plain-c.patch
+ source = 020-pstoedit-fix-pkgconfig-includedir.patch
+ sha256sums = 075a7daeaba75f3d1922beae680cc3662bb373c7e3826282229fda2733ac62ea
+ sha256sums = ee60574e10d04e723d6b06ef33de45911e7515846182bb66ac56078dde3bace9
+ sha256sums = 1ad78e582d0f287f9a9ef545bb27fb50f0ef791ce539a73644a68ad3228a6267
pkgname = pstoedit-nomagick
diff --git a/010-pstoedit-fix-plain-c.patch b/010-pstoedit-fix-plain-c.patch
new file mode 100644
index 000000000000..02060f836cd0
--- /dev/null
+++ b/010-pstoedit-fix-plain-c.patch
@@ -0,0 +1,41 @@
+--- a/src/pstoedit.cpp
++++ b/src/pstoedit.cpp
+@@ -327,6 +327,11 @@ extern FILE *yyin; // used by lexer
+ // otherwise we could declare it locally where it is used
+
+
++extern "C" DLLEXPORT void loadpstoeditplugins_plainC(const char *progname, int verbose)
++{
++ return loadpstoeditplugins(progname, cerr, (bool) verbose);
++}
++
+ static void usage(ostream & outstream, bool forTeX, bool withdetails, bool withcategories )
+ {
+ if (withcategories) {
+--- a/src/pstoedit.h
++++ b/src/pstoedit.h
+@@ -100,8 +100,13 @@ void clearPstoeditDriverInfo_plainC(struct DriverDescription_S * ptr);
+
+ #ifdef __cplusplus
+ extern "C" DLLEXPORT
+-#endif
+ void loadpstoeditplugins(const char* progname, std::ostream & errstream, bool verbose);
++#endif
++
++#ifdef __cplusplus
++extern "C" DLLEXPORT
++#endif
++void loadpstoeditplugins_plainC(const char* progname, int verbose);
+
+ #ifdef __cplusplus
+ extern "C" DLLEXPORT
+--- a/src/pstoedit.h
++++ b/src/pstoedit.h
+@@ -37,6 +37,7 @@
+ #endif
+
+ #include "pstoedll.h"
++#include <stdbool.h>
+
+ typedef int (*execute_interpreter_function)(int argc, const char * const argv[]);
+
diff --git a/020-pstoedit-fix-pkgconfig-includedir.patch b/020-pstoedit-fix-pkgconfig-includedir.patch
new file mode 100644
index 000000000000..a0a50382fc12
--- /dev/null
+++ b/020-pstoedit-fix-pkgconfig-includedir.patch
@@ -0,0 +1,17 @@
+--- a/config/pstoedit.pc.in
++++ b/config/pstoedit.pc.in
+@@ -1,7 +1,7 @@
+ prefix=@prefix@
+ exec_prefix=@exec_prefix@
+ libdir=@libdir@
+-includedir=@includedir@
++includedir=@includedir@/pstoedit
+
+ Name: pstoedit
+ Description: converts PostScript(TM) and PDF files to other vector graphic formats
+@@ -8,4 +8,4 @@
+ Version: @VERSION@.0
+ Requires:
+ Libs: -L@libdir@ -lpstoedit @CXX_STD_LIB@ @CXX_RUNTIME_LIB@ @LIBLD_LDFLAGS@
+-Cflags: -I@includedir@
++Cflags: -I@includedir@/pstoedit
diff --git a/PKGBUILD b/PKGBUILD
index 2d633e5e98bd..d065d588467b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=pstoedit-nomagick
-pkgver=3.78
+pkgver=4.00
pkgrel=1
pkgdesc='Translates PS/PDF graphics to other vector formats (no ImageMagick dependency)'
arch=('x86_64')
@@ -10,8 +10,17 @@ license=('GPL')
depends=('gd' 'ghostscript' 'ming' 'libemf' 'libzip' 'plotutils' 'zlib')
provides=('pstoedit')
conflicts=('pstoedit')
-source=("https://sourceforge.net/projects/pstoedit/files/pstoedit/${pkgver}/pstoedit-${pkgver}.tar.gz")
-sha256sums=('8cc28e34bc7f88d913780f8074e813dd5aaa0ac2056a6b36d4bf004a0e90d801')
+source=("https://sourceforge.net/projects/pstoedit/files/pstoedit/${pkgver}/pstoedit-${pkgver}.tar.gz"
+ '010-pstoedit-fix-plain-c.patch'
+ '020-pstoedit-fix-pkgconfig-includedir.patch')
+sha256sums=('075a7daeaba75f3d1922beae680cc3662bb373c7e3826282229fda2733ac62ea'
+ 'ee60574e10d04e723d6b06ef33de45911e7515846182bb66ac56078dde3bace9'
+ '1ad78e582d0f287f9a9ef545bb27fb50f0ef791ce539a73644a68ad3228a6267')
+
+prepare() {
+ patch -d "pstoedit-${pkgver}" -Np1 -i "${srcdir}/010-pstoedit-fix-plain-c.patch"
+ patch -d "pstoedit-${pkgver}" -Np1 -i "${srcdir}/020-pstoedit-fix-pkgconfig-includedir.patch"
+}
build() {
cd "pstoedit-${pkgver}"