summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..36c6cee7e2e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Wed Sep 27 22:17:36 UTC 2017
+pkgbase = psvtools-git
+ pkgdesc = PSV file trimmer, restoration, and validation utility (Python). (GIT version
+ pkgver = 0.1.0.3.gde2e2a9
+ pkgrel = 1
+ url = https://github.com/kageurufu/psvtools
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python-setuptools
+ provides = psvtools
+ conflicts = psvtools
+ source = git+https://github.com/kageurufu/psvtools.git
+ sha256sums = SKIP
+
+pkgname = psvtools-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a0bb87d9a10
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+pkgname=psvtools-git
+pkgver=0.1.0.3.gde2e2a9
+pkgrel=1
+arch=('any')
+pkgdesc="PSV file trimmer, restoration, and validation utility (Python). (GIT version"
+url='https://github.com/kageurufu/psvtools'
+license=('MIT')
+depends=('python-setuptools')
+makedepends=('git')
+conflicts=('psvtools')
+provides=('psvtools')
+source=('git+https://github.com/kageurufu/psvtools.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd psvtools
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+package() {
+ cd psvtools
+ python setup.py install --root="${pkgdir}" --optimize=1
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}