summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
-rw-r--r--puddletag-mutagen1.34.patch24
3 files changed, 12 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44e90410ca0d..b9739b5ffc35 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = puddletag
- pkgdesc = A tag editor for GNU/Linux
+ pkgdesc = An audio tag editor for GNU/Linux
pkgver = 1.2.0
- pkgrel = 1
- url = http://puddletag.sourceforge.net
+ pkgrel = 2
+ url = https://docs.puddletag.net/
arch = any
- license = GPL
+ license = GPL3
depends = chromaprint
- depends = mutagen
+ depends = python2-mutagen
depends = python2-configobj
depends = python2-musicbrainz2
depends = python2-pyparsing
diff --git a/PKGBUILD b/PKGBUILD
index 575c7ed5c1c9..048123bdce7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
-# $Id: PKGBUILD 197348 2016-11-29 09:09:36Z alucryd $
-# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Maintainer: Morgenstern <charles [at] charlesbwise [dot] com>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
# Contributor: Lucky <archlinux@builds.lucky.li>
# Contributor: Farhad Shahbazi <farhad@enthusiasm.cc>
pkgname=puddletag
pkgver=1.2.0
-pkgrel=1
-pkgdesc='A tag editor for GNU/Linux'
-url='http://puddletag.sourceforge.net'
-license=('GPL')
+pkgrel=2
+pkgdesc='An audio tag editor for GNU/Linux'
+url='https://docs.puddletag.net/'
+license=('GPL3')
arch=('any')
-depends=('chromaprint' 'mutagen' 'python2-configobj' 'python2-musicbrainz2'
+depends=('chromaprint' 'python2-mutagen' 'python2-configobj' 'python2-musicbrainz2'
'python2-pyparsing' 'python2-pyqt4')
optdepends=('python2-pillow: FLAC cover art'
'quodlibet: QuodLibet library support')
@@ -19,19 +19,16 @@ sha256sums=('95e4867fd04c5349f19de1b5f3c1f2336d3b66da08c076fb175ef8f7589dc80d')
prepare() {
cd puddletag-${pkgver}/source
-
sed -i 's|^#!.*python$|#!/usr/bin/python2|' $(grep -rl '^#!.*python')
}
build() {
cd puddletag-${pkgver}/source
-
python2 setup.py config
}
package() {
cd puddletag-${pkgver}/source
-
python2 setup.py install --root="${pkgdir}" --optimize='1'
}
diff --git a/puddletag-mutagen1.34.patch b/puddletag-mutagen1.34.patch
deleted file mode 100644
index 578d18a42a2f..000000000000
--- a/puddletag-mutagen1.34.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 6fd73f9d3442c729a771d160430bd44fb003eb69 Mon Sep 17 00:00:00 2001
-From: b_b <brunobergot@gmail.com>
-Date: Wed, 27 Jul 2016 11:27:14 +0200
-Subject: [PATCH] Fix for BitPaddedInt import error
-
-This one fix an import error i get with latest python-mutagen 1.34.999+1301~0c8997f-0~ppa0~trusty from https://launchpad.net/~lazka/+archive/ubuntu/dumpingplace
----
- source/puddlestuff/audioinfo/_compatid3.py | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/source/puddlestuff/audioinfo/_compatid3.py b/source/puddlestuff/audioinfo/_compatid3.py
-index 7d73e27..a7a599f 100644
---- a/source/puddlestuff/audioinfo/_compatid3.py
-+++ b/source/puddlestuff/audioinfo/_compatid3.py
-@@ -23,7 +23,8 @@
- import mutagen
- from mutagen._util import insert_bytes
- from mutagen.id3 import ID3, Frame, Frames, Frames_2_2, TextFrame, TORY, \
-- TYER, TIME, APIC, IPLS, TDAT, BitPaddedInt, MakeID3v1
-+ TYER, TIME, APIC, IPLS, TDAT, MakeID3v1
-+from mutagen.id3._util import BitPaddedInt
-
- SEPARATOR = ' / '
-